Bug 602948 - SRP LUNs not found at boot time
SRP LUNs not found at boot time
Status: CLOSED DUPLICATE of bug 591169
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rdma (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Doug Ledford
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-11 01:48 EDT by Justin Clift
Modified: 2010-08-02 10:20 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 10:20:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against the rdma init script (1.81 KB, patch)
2010-06-11 05:06 EDT, Justin Clift
no flags Details | Diff

  None (edit)
Description Justin Clift 2010-06-11 01:48:40 EDT
Description of problem:

In RHEL 6 beta 1, SRP LUNs that should be found and attached to the server at boot time aren't.

Instead, the user has to manually run a script or create their own boot script to achieve this.


Version-Release number of selected component (if applicable):

rdma-1.0-6.el6.noarch.rpm


How reproducible:

Every time.


Steps to Reproduce:
1. Configure remote SRP targets for access by host server.
2. Verify connectivity from host server using "ibsrpdm -c" and/or "srp_daemon -eo".
3. Add LUN wwid's to host device mapper multipath configuration file /etc/multipath.conf file
4. Enable SRP module in /etc/rdma/rdma.conf on host.
5. Use chkconfig on host to enable rdma service at boot.
6. Reboot.  The LUNs are not found.  (This is the problem)
  
Actual results:

No SRP LUNs available on the host.  Subsequent scripts and programs depending upon them then fail.


Expected results:

SRP LUNs to be attached to the host and made available, as per other storage types.  (ie iSCSI, FC, etc)


Additional info:

Do you reckon this could be resolved before RHEL 6 final ships?

SRP configuration information is presently being written for inclusion in the RHEL 6 Virtualization Guide.  Thinking it would be better to have this "just work" rather than instruct end users to create their own init script to manage this.

?
Comment 2 RHEL Product and Program Management 2010-06-11 02:03:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Justin Clift 2010-06-11 05:06:19 EDT
Created attachment 423177 [details]
Patch against the rdma init script

Attached is a patch against the latest rdma init.d script I could find (in Fedora 14 rawhide).

The first addition to start() is pretty much lifted from the OFED 1.5.2-rc1 version, introducing a new "SRP_DAEMON_ENABLE=yes" variable in your /etc/rdma/rdma.conf.

The OFED code for flushing the multipath device maps in stop() was completely non-functional however, so that's been re-worked.  It now correctly retrieves device map names and flushes them, allowing the ib_srp module to be nicely removed.

This is tested and working on the local SRP connected lab systems here.
Comment 4 RHEL Product and Program Management 2010-07-15 10:51:54 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Doug Ledford 2010-08-02 10:20:21 EDT

*** This bug has been marked as a duplicate of bug 591169 ***

Note You need to log in before you can comment on or make changes to this bug.