Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591242 - MTP plugin grabs PTP camera, blocking gphoto2
MTP plugin grabs PTP camera, blocking gphoto2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
16
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 694605 755299 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 13:51 EDT by James Ettle
Modified: 2011-12-20 16:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-20 16:45:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 615743 None None None Never

  None (edit)
Description James Ettle 2010-05-11 13:51:19 EDT
Description of problem:
When the MTP plugin is enabled, Rhythmbox will grab the USB device for a PTP camera before gvfs's gphoto2 component has the chance. This blocks gphoto2 rendering the camera inaccessible until Rhythmbox's MTP plugin is disabled.

Version-Release number of selected component (if applicable):
rhythmbox-0.12.6-5.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Start Rhythmbox.
2. Enable MTP plugin.
3. Connect PTP camera.
  
Actual results:
Rhythmbox grabs camera.

Expected results:
Rhythmbox ignores camera.

Additional info:
Comment 1 James Ettle 2010-05-26 17:52:37 EDT
Still present in F13, rhythmbox-0.12.8-3.fc13.i686. Moreover, this plugin is enabled by default.
Comment 2 James Ettle 2011-01-06 07:41:35 EST
Still present in F14, rhythmbox-0.13.2-1.fc14.x86_64.
Comment 3 seventhguardian 2011-04-30 11:42:49 EDT
*** Bug 694605 has been marked as a duplicate of this bug. ***
Comment 4 seventhguardian 2011-04-30 11:47:14 EDT
I believe this was fixed upstream (see upstream bug report)..
Comment 5 Gert Vervoort 2011-11-20 09:28:47 EST
*** Bug 755299 has been marked as a duplicate of this bug. ***
Comment 6 Gert Vervoort 2011-11-20 09:30:17 EST
Same problem is still present in Fedora 16
Comment 7 James Ettle 2011-12-20 16:04:03 EST
(In reply to comment #6)
> Same problem is still present in Fedora 16

Seems fixed for me with rhythmbox-2.90.1-17.git20110927.fc16.x86_64 , Gert can you confirm before I close this?
Comment 8 Gert Vervoort 2011-12-20 16:35:43 EST
It will start shotwell and shotwell sees my camera, however shotwell will fail with "Uable to fetch previes from the camera: Unspecified error (-1)".
(see also bug 755299).

A quick experiment shows, that the mtp plugin does not give any problems, these problems appear to be caused by the iPod plugin. 

Looks like a different problem, so I think this bug can be closed. I will open a new one for the iPod plugin problem.

Note You need to log in before you can comment on or make changes to this bug.