Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591275 - AttributeError: 'NoneType' object has no attribute 'rfind'
AttributeError: 'NoneType' object has no attribute 'rfind'
Status: CLOSED DUPLICATE of bug 589967
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
anaconda_trace_hash:1048f489f82bf8c39...
:
Depends On:
Blocks: 582286
  Show dependency treegraph
 
Reported: 2010-05-11 15:21 EDT by Alexander Todorov
Modified: 2010-05-11 16:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 16:27:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (49.75 KB, text/plain)
2010-05-11 15:21 EDT, Alexander Todorov
no flags Details
Attached traceback automatically from anaconda. (49.76 KB, text/plain)
2010-05-11 15:38 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2010-05-11 15:21:04 EDT
The following was filed automatically by anaconda:
anaconda 13.21.36 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/posixpath.py", line 111, in basename
    i = p.rfind('/') + 1
  File "/usr/lib/anaconda/storage/devicetree.py", line 1360, in handleUdevDiskLabelFormat
    bypath = os.path.basename(deviceNameToDiskByPath(device.name))
  File "/usr/lib/anaconda/storage/devicetree.py", line 1715, in handleUdevDeviceFormat
    self.handleUdevDiskLabelFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1299, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1965, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 379, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 103, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 657, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1107, in <module>
    anaconda.intf.run(anaconda)
AttributeError: 'NoneType' object has no attribute 'rfind'
Comment 1 Alexander Todorov 2010-05-11 15:21:07 EDT
Created attachment 413232 [details]
Attached traceback automatically from anaconda.
Comment 2 Alexander Todorov 2010-05-11 15:24:21 EDT
Hi,
just started new virtual guest with 0506.3 tree

1) Create new KVM domU, using virtio
2) Create new 20G image file
3) Leave default of 512MB memory
4) Proceed with install
5) Anaconda now defaults to text mode - traceback happens when searching for disks I believe.
Comment 3 Alexander Todorov 2010-05-11 15:38:23 EDT
Created attachment 413237 [details]
Attached traceback automatically from anaconda.
Comment 4 David Cantrell 2010-05-11 16:27:54 EDT

*** This bug has been marked as a duplicate of bug 589967 ***

Note You need to log in before you can comment on or make changes to this bug.