Bug 591311 - RHEL6.0 Beta 1 fails to reboot after kickstart install
RHEL6.0 Beta 1 fails to reboot after kickstart install
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
high Severity high
: rc
: 6.0
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-11 16:47 EDT by Issue Tracker
Modified: 2010-10-23 11:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-19 21:13:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (27.00 KB, text/plain)
2010-05-11 17:00 EDT, Chris Lumens
no flags Details

  None (edit)
Description Issue Tracker 2010-05-11 16:47:50 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2010-05-11 16:47:51 EDT
Event posted on 04-27-2010 12:42pm EDT by sandy.garza

Description of problem:
 The install runs correctly installs the boot loader and runs the post-install scripts (we remove all of ours from the kickstart file, so there are none). The screen then goes blank and nothing happens. There is still a graphic mouse, but know mouse or keyboard action will cause it to reboot. If we telnet to the server we are in anaconda. If we power cycle the server it will boot RHEL6.0. We tried doing this using the "text" kernel parameter which tells it not to use the UI. Again this runs to completion, but then it print a line at the bottom that says "Enter Control C or Cntl-Alt-Delete to reboot the system. We have never seen this before. Using the "nomodeset" option did not help 

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info: Tested on DL360 G5.

Sosreport forthcoming.
This event sent from IssueTracker by dwa  [HP-ProLiant]
 issue 816913
Comment 2 Issue Tracker 2010-05-11 16:47:52 EDT
Event posted on 04-27-2010 02:58pm EDT by sandy.garza

File uploaded: sosreport-Hrifkin.1001031472-20100427221505-8035.tar.bz2

This event sent from IssueTracker by dwa  [HP-ProLiant]
 issue 816913
it_file 608923
Comment 3 David Aquilina 2010-05-11 16:49:04 EDT
Created attachment 413257 [details]
kickstart file in use
Comment 4 Chris Lumens 2010-05-11 16:58:19 EDT
Can you also attach /tmp/anaconda.log and /tmp/program.log?  Thanks.
Comment 5 Chris Lumens 2010-05-11 16:59:50 EDT
Sorry, I see them in the sosreport.  Attaching for future convenience.  They don't look helpful though.
Comment 6 Chris Lumens 2010-05-11 17:00:41 EDT
Created attachment 413262 [details]
anaconda.log
Comment 7 RHEL Product and Program Management 2010-05-11 17:57:09 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 8 Brian Lane 2010-05-17 12:58:55 EDT
Could you attach the other /tmp/*log files? This sounds like there is an error right at the end of the install (hence the ctrl-c prompt).

Does tty5 show anything unusual when it is done? Or is there any information right above the Ctrl-C prompt?

You might also try not passing nokill to it.
Comment 9 Brian Lane 2010-05-19 21:13:56 EDT
This is due to passing nokill on the kernel command line.

Note You need to log in before you can comment on or make changes to this bug.