Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591366 - outgoing migrate exec: can be inordinately slow
outgoing migrate exec: can be inordinately slow
Status: CLOSED DUPLICATE of bug 609261
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.1
All Linux
low Severity medium
: beta
: ---
Assigned To: Karen Noel
Virtualization Bugs
:
Depends On:
Blocks: 580953
  Show dependency treegraph
 
Reported: 2010-05-11 22:57 EDT by Charles Duffy
Modified: 2013-01-09 06:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-18 05:25:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Duffy 2010-05-11 22:57:02 EDT
Description of problem:

  When migrating to a file using "migrate exec:" (as with libvirt's virDomainSave), saving 2GB of state can take upwards of 10 minutes on a quite high-performance server.

  This happens only when the file descriptor on which the migration is occurring is marked non-blocking; commenting out the socket_set_nonblock() call in migration-exec.c:exec_start_outgoing_migration works around the issue, resulting in a save-to-disk time on the scale of 2 minutes for this same guest.

  The symptoms of the issue were described by detail by Pierre Riteau in a mailing list post titled "[BUG] Regression of exec migration" on 8/27/2009.

  Anthony Ligouri noted in the following thread that setting this socket to be non-blocking is essential for live migration support. However, this performance degredation happens even when a guest is stopped during the migration process.

Version-Release number of selected component (if applicable):

  qemu-kvm-0.12.1.2-2.17.el6.x86_64
Comment 2 RHEL Product and Program Management 2010-05-12 00:53:02 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 RHEL Product and Program Management 2010-07-15 09:59:25 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 5 Charles Duffy 2010-07-15 10:38:04 EDT
Please consider this for a future release (ie. RHEL6.1).
Comment 8 Avi Kivity 2010-11-18 05:25:21 EST

*** This bug has been marked as a duplicate of bug 609261 ***

Note You need to log in before you can comment on or make changes to this bug.