Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 609261 - Exec outgoing migration is too slow
Exec outgoing migration is too slow
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
medium Severity high
: rc
: ---
Assigned To: Karen Noel
Virtualization Bugs
:
: 591366 (view as bug list)
Depends On:
Blocks: 580953
  Show dependency treegraph
 
Reported: 2010-06-29 15:18 EDT by Juan Quintela
Modified: 2013-01-09 17:47 EST (History)
6 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.95.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-20 06:31:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juan Quintela 2010-06-29 15:18:26 EDT
Description of problem:

Exec migration is very slow (writes at the speed of 1.5MB/s on my hardware).

Version-Release number of selected component (if applicable):

All.

How reproducible:
Allways.

Steps to Reproduce:
1. start qemu
2. migrate in command line with something like:
   migrate -d "exec: dd of=/tmp/kkk"
3.
  
Actual results:

very low write speed (~1MB/s)

Expected results:

fastest write (~30MB/s at least)

Additional info:
Comment 1 Juan Quintela 2010-06-29 15:20:50 EDT
Problem is that code is using double buffering (using FILE on top of QEMUFile abstraction).  With a hack to change fwrite() to write() speeds got back to normal.  Will fix things properly.
Comment 3 Avi Kivity 2010-07-07 13:08:45 EDT
Real problem is that the small pipe buffers fill up easily, and QEMUFileBuffered clams up until 100 ms pass.

Fix is to let migration know we're ready when the pipes come back.
Comment 8 Mike Cao 2010-07-20 06:29:29 EDT
Verified in qemu-kvm-0.12.1.2-2.96.el6 ,Reproduced in Reproduce in qemu-kvm-0.12.1.2-2.94.el6

Steps:
1. start qemu-kvm
2. {"execute":"migrate","arguments":{"uri":"dd of=/home/tt"}}

Actual Results:
the write speed is 18MB/s ,the read speed is 91Mb/s

The bug has already been fixed.
Comment 9 Mike Cao 2010-07-20 06:30:50 EDT
According to comment #8 ,close this issue.
Comment 10 Avi Kivity 2010-11-18 05:25:21 EST
*** Bug 591366 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.