Bug 591570 - Random icon corruption on KDE desktop
Random icon corruption on KDE desktop
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 11:05 EDT by Stefan Becker
Modified: 2011-05-15 03:08 EDT (History)
5 users (show)

See Also:
Fixed In Version: kernel-2.6.35.6-37.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-15 03:08:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example screen shot showing the KDE taskbar (64.01 KB, image/png)
2010-05-12 11:05 EDT, Stefan Becker
no flags Details
dmesg logfile (79.09 KB, text/plain)
2010-05-12 11:06 EDT, Stefan Becker
no flags Details
X server logfile (414.36 KB, text/plain)
2010-05-12 11:06 EDT, Stefan Becker
no flags Details

  None (edit)
Description Stefan Becker 2010-05-12 11:05:43 EDT
Created attachment 413453 [details]
Example screen shot showing the KDE taskbar

Description of problem:

This is not the same as bug #590216. I have installed that new driver version and my problem still appears.

At startup everything is fine but after a while icons get randomly corrupted. I have also seen image corruptions for the cover images in amarok. If the application does a redraw then the image appears OK again.

Version-Release number of selected component (if applicable):

kernel-2.6.33.2-57.fc13.x86_64
kernel-2.6.33.3-72.fc13.x86_64
kernel-2.6.33.3-85.fc13.x86_64
xorg-x11-server-Xorg-1.8.0-12.fc13.x86_64
xorg-x11-drv-nouveau-0.0.16-5.20100423git13c1043.fc13.x86_64
libdrm-2.4.20-1.fc13.x86_64
mesa-libGL-7.8.1-6.fc13.x86_64

How reproducible:
Always

Additional info:

01:00.0 VGA compatible controller [0300]: nVidia Corporation G94 [GeForce 9800M GTS] [10de:062c] (rev a1)
Comment 1 Stefan Becker 2010-05-12 11:06:05 EDT
Created attachment 413454 [details]
dmesg logfile
Comment 2 Stefan Becker 2010-05-12 11:06:31 EDT
Created attachment 413455 [details]
X server logfile
Comment 3 Stefan Becker 2010-05-12 11:07:56 EDT
Oops, too much copy & paste. That is of course kernel:

Linux baraddur 2.6.33.3-85.fc13.x86_64 #1 SMP Thu May 6 18:09:49 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
Comment 4 Ben Skeggs 2010-06-29 00:13:15 EDT
Hey Stefan,

Just seen your comment on the recent update.  Is the problem still identical to before?
Comment 5 Stefan Becker 2010-06-29 01:03:19 EDT
Yes, no changes. I had hoped that the problem would be fixed after reading the changelog of the latest driver update...
Comment 6 Stefan Becker 2010-08-09 11:42:10 EDT
The new kernel-2.6.34.2-34.fc13.x86_64 with the fix for bug #602956 doesn't help. Icons are still corrupted :-/
Comment 7 Stefan Becker 2010-09-30 14:51:45 EDT
Just preupgraded the machine to F14Beta and still have the same issue.

kernel-2.6.35.4-28.fc14.x86_64
libdrm-2.4.21-3.fc14.x86_64
mesa-dri-drivers-experimental-7.9-0.8.fc14.x86_64
mesa-libGL-7.9-0.8.fc14.x86_64
xorg-x11-drv-nouveau-0.0.16-12.20100920gitf1ac413.fc14.x86_64
xorg-x11-server-Xorg-1.9.0-9.fc14.x86_64
Comment 8 Ben Skeggs 2010-10-01 02:08:07 EDT
I'm not sure if it'll help, but the kernel that's building now has an additional fix for a corruption issue I managed to track down finally:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2505534
Comment 9 Stefan Becker 2010-10-03 05:19:41 EDT
Sorry for the late reply, but I wanted to check the new kernel a little bit longer. I haven't seen any icon corruptions with 2.6.35.6-37.fc14.x86_64 for two days, so I assume the issue is fixed.
Comment 10 Ben Skeggs 2010-10-03 18:07:03 EDT
Ah, excellent :)  Thanks for letting me know.  That was a pain to track down, I couldn't reproduce it in normal circumstances at all, had to resort to some tricks.  Glad it's good now though!
Comment 11 Adam Williamson 2010-10-07 15:41:41 EDT
of course, we need kernel team to submit this or a later build as an update to make sure the fix makes F14.
Comment 12 Stefan Becker 2011-05-15 03:08:28 EDT
This has been fixed. Closing.

Note You need to log in before you can comment on or make changes to this bug.