Bug 591713 - KickstartValueError: The following problem occurred on line 15 of the kickstart file: Tried to use undefined partition raid.None in RAID specificationusUsing
KickstartValueError: The following problem occurred on line 15 of the kicksta...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
anaconda_trace_hash:23e61d66771883eb1...
: Reopened
: 597347 628471 667089 (view as bug list)
Depends On:
Blocks: 647893
  Show dependency treegraph
 
Reported: 2010-05-12 17:22 EDT by Dennis Gilmore
Modified: 2011-05-19 08:29 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-13.21.85-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 08:29:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (87.70 KB, text/plain)
2010-05-12 17:22 EDT, Dennis Gilmore
no flags Details

  None (edit)
Description Dennis Gilmore 2010-05-12 17:22:34 EDT
The following was filed automatically by anaconda:
anaconda 13.21.20.5 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/kickstart.py", line 826, in execute
    raise KickstartValueError, formatErrorMsg(self.lineno, msg="Tried to use undefined partition %s in RAID specification" % member)
  File "/usr/lib/anaconda/kickstart.py", line 1086, in execute
    obj.execute(self.anaconda)
  File "/usr/bin/anaconda", line 1035, in <module>
    ksdata.execute()
KickstartValueError: The following problem occurred on line 15 of the kickstart file:

Tried to use undefined partition raid.None in RAID specification
Comment 1 Dennis Gilmore 2010-05-12 17:22:36 EDT
Created attachment 413569 [details]
Attached traceback automatically from anaconda.
Comment 2 Dennis Gilmore 2010-05-12 17:24:33 EDT
I used the partitioning as written out by anaconda on a installed system. It resulted in unreproducible installs
Comment 3 Chris Lumens 2010-05-12 17:25:44 EDT
What happens if you change your kickstart file to use anything other than "None" for these names?
Comment 4 Dennis Gilmore 2010-05-12 17:27:21 EDT
Let me try
Comment 6 RHEL Product and Program Management 2010-05-12 19:18:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Chris Lumens 2010-06-04 13:50:14 EDT
The anaconda-ks.cfg is provided as a basis for getting started with kickstart.  The partitioning section in particular is commented out as it's up to you to verify it's correct.  We've left it this way for as long as I can remember.

The fact that you've got "None" in there means we are not being provided with a UUID for those RAID volumes.  If you can reproduce this with something other than "None" in those specifiers, it'd be a much more high priority problem.
Comment 8 RHEL Product and Program Management 2010-06-04 13:55:22 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 9 Dennis Gilmore 2010-06-08 13:07:58 EDT
It works with Values specified there.  and it works with the partitioning as written out by anaconda in RHEL-5,  this is a regression from RHEL-5's anaconda and at the very least needs documenting because i was unable to find any anywhere.
Comment 10 David Cantrell 2010-06-16 14:54:00 EDT
*** Bug 597347 has been marked as a duplicate of this bug. ***
Comment 11 Chris Lumens 2010-08-30 09:02:51 EDT
*** Bug 628471 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2010-12-16 10:41:00 EST
This should be fixed in the next build of anaconda.  I tested with LVM built on top of a combination of RAID and regular partitions, and the IDs matched up correctly.
Comment 15 Chris Lumens 2011-01-04 10:15:09 EST
*** Bug 667089 has been marked as a duplicate of this bug. ***
Comment 17 Alexander Todorov 2011-04-05 07:22:51 EDT
Tested with anaconda-13.21.109. The anaconda-ks.cfg file doesn't contain raid.None entries, instead there is: 

part raid.253002 --size=9000
Comment 18 errata-xmlrpc 2011-05-19 08:29:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0530.html

Note You need to log in before you can comment on or make changes to this bug.