Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 591746 - xsettings-kde should set Gtk/CursorThemeName based on the KDE setting
xsettings-kde should set Gtk/CursorThemeName based on the KDE setting
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xsettings-kde (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
: 612835 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-12 19:16 EDT by nucleo
Modified: 2011-03-23 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: xsettings-kde-0.12-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-23 18:53:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2010-05-12 19:16:26 EDT
Description of problem:
When in KDE settings cursor theme changed from default to for example bluecurve GTK applications still use default dmz theme.

Version-Release number of selected component (if applicable):
xsettings-kde-0.11

Steps to Reproduce:
1. install bluecurve-cursor-theme
2. set bluecurve cursor theme in KDE settings
3. run for example firefox and konqueror

Actual results:
KDE apps use bluecurve theme but GTK apps use dmz.

Expected results:
KDE cursor theme settings should be used by GTK applications.
Comment 1 nucleo 2010-11-29 19:04:21 EST
Cursor Style now can be set in kcm-gtk.
Comment 2 Kevin Kofler 2011-03-14 13:54:09 EDT
For reference, the equivalent KDE setting is kcminputrc [Mouse] cursorTheme.

I'm working on this.
Comment 3 Fedora Update System 2011-03-14 15:10:58 EDT
xsettings-kde-0.12-3.fc15,kcm-gtk-0.5.3-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xsettings-kde-0.12-3.fc15,kcm-gtk-0.5.3-7.fc15
Comment 4 Fedora Update System 2011-03-14 15:11:31 EDT
xsettings-kde-0.12-3.fc14,kcm-gtk-0.5.3-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xsettings-kde-0.12-3.fc14,kcm-gtk-0.5.3-7.fc14
Comment 5 Fedora Update System 2011-03-14 15:12:20 EDT
xsettings-kde-0.12-3.fc13,kcm-gtk-0.5.3-7.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/xsettings-kde-0.12-3.fc13,kcm-gtk-0.5.3-7.fc13
Comment 6 collura 2011-03-16 23:56:55 EDT
just ran across this buy when the fix came through f14-kde-updates-testing.

works for firefox cursor.

one less user on my back lol.

thanks.

ps: closing duplicate https://bugzilla.redhat.com/show_bug.cgi?id=612835
Comment 7 collura 2011-03-17 00:12:02 EDT
*** Bug 612835 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2011-03-19 01:49:59 EDT
xsettings-kde-0.12-3.fc15, kcm-gtk-0.5.3-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2011-03-23 18:53:09 EDT
xsettings-kde-0.12-3.fc13, kcm-gtk-0.5.3-7.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-03-23 19:00:06 EDT
xsettings-kde-0.12-3.fc14, kcm-gtk-0.5.3-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.