Bug 612835 - fc13 kde - oxygen cursor reverts to regular cursor when mouse over firefox
fc13 kde - oxygen cursor reverts to regular cursor when mouse over firefox
Status: CLOSED DUPLICATE of bug 591746
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
14
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-09 04:03 EDT by collura
Modified: 2011-03-17 00:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 00:12:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description collura 2010-07-09 04:03:33 EDT
Description of problem:

oxygen-cursor-themes cursor reverts to standard cursor when mouse over a firefox window.

with mouse over some non-firefox program window still correctly see oxygen cursor.  (works fine in 'konsole' terminal window for example)

works ok in fc12_gnome but not fc13_kde. 


Version-Release number of selected component (if applicable):

broken in fc13_kde:
oxygen-cursor-themes-4.4.5-1.fc13.noarch
firefox-3.6.4-1.fc13.x86_64 
compiz---not installed

worked in fc12_gnome:
oxygen-cursor-themes-4.4.4-1.fc12.noarch
firefox-3.5.10-1.fc12.x86_64
compiz-0.8.2-24.fc12.x86_64


How reproducible:

always


Steps to Reproduce:
1. with mouse over desktop see oxygen cursor
2. with mouse over firefox window titlebar still see oxygen cursor
3. with mouse over firefox window body see regular non-oxygen cursor instead of an expected oxygen cursor that should see
4. click on 'tools' (or other menu) in firefox menu bar and get oxygen cursor as should until you move over on one of the items in the tools submenu we opened at which point the cursor turns back into regular non-oxygen cursor instead of an oxygen cursor that should see

( however, IF one of the tools (or other menu) submenu item has ANOTHER LAYER OF SUBMENU (denoted with a '>' at end of line) then mousing over that line item gives the CORRECT oxygen cursor as expected while the rest of the line items without further submenu layers still only give the regular non-oxygen cursor )

  
Actual results:

dont see oxygen cursor in firefox in fc13_kde 


Expected results:

expect to see oxygen cursor as did in fc12_gnome


Additional info:

0) filing against firefox here since it only seems to work wrong in firefox. 

note that fc12_gnome didnt support 3d effects for my card while fc13_kde(and gnome i think) does [yay]
so might have been effect related but happens in fc13 with 3d effects disabled (and compiz doesnt even seem to be installed on the fc13_kde installation)
but otherwise might think would have been related to:

- bug#599011 "Can't change cursor theme" reported against compiz
(though i can change cursor theme just doesnt seem to engage fully as described above)

- bug#531380 "Autoraise not working" reported against compiz
(i have seen some authorization windows remain burried under a pile of windows during a package install
that stalls until i remember to go looking for themso maybe there is confusion about what the current window is
but dont see how that effects the implentation of the cursor theme)

1) just out of curiosity installed compiz-0.8.6.-1.fc13.x86_64 on the fc13_kde installation to see it had an effect but doesnt seem to.

2) only skimmed but didnt notice any errors that looked related in: 

var log messages

xsession-errors
Comment 1 collura 2010-07-09 14:31:19 EDT
incidentally, 'firefox -safe-mode' has same issue so probably not an addon
Comment 2 collura 2010-07-10 10:13:58 EDT
related to some gtk2 change?

https://bugzilla.mozilla.org/show_bug.cgi?id=310924 

"While the gtk2 widget code makes use of some themeable cursors (those available
in stock gtk2 with gdk_cursor_new), it only uses its builtin images for some
other cursors"
Comment 3 Joerg Mensmann 2010-09-21 09:55:34 EDT
Seems to be more of a gtk problem, as I also get incorrectly themed cursors in gimp and (gtk-)emacs. Not for all types of cursors, however.

This forum post (in German) describes the same issue, and as a workaround proposes to replace the standard "dmz-aa" with the wanted custom theme:
http://www.fedoraforum.de/viewtopic.php?t=20240
Comment 4 collura 2010-10-07 01:29:21 EDT
in fc14-beta-kde the oxygen-cursor still reverts to standard-cursor as described above

changing version to fc14
Comment 5 Panos Kavalagios 2010-11-17 03:58:44 EST
Indeed, I've installed oxygen-cursor-theme and switched to black oxygen theme. On firefox and thunderbird the theme reverts back to the default.
Comment 6 Panos Kavalagios 2010-11-17 04:58:38 EST
Workaround:

# vi /etc/gtk-2.0/gtkrc

and either put in comment gtk-cursor-theme-name variable or set it to your desired theme:

gtk-cursor-theme-name = "Oxygen_Black"

It's set to "dmz-aa". You might want to do the same on /etc/gtk-3.0/gtkrc. Other distributions do not hardcode those stuff to gtkrc and are free of this bug on KDE environments.
Comment 7 Panos Kavalagios 2010-11-17 06:09:29 EST
For KDM the change must be done in the following file:

$ cat /usr/share/icons/default/index.theme
[Icon Theme]
Inherits=Oxygen_Black
Comment 8 collura 2011-03-17 00:12:02 EDT
hmm i missed a duplicate of this bug.  

will close this one as a duplicate of bug#591746 . 

on the bright side bug#591746 has a fix pending in updates-testing of f14-kde-x86_64 of: 

   xsettings-kde-0.12-3.fc14 
   kcm-gtk-0.5.3-7.fc14

which seem to fix the issue for me, ya.


however if during their testing you find an issue then should report problems to: 

https://admin.fedoraproject.org/updates/xsettings-kde-0.12-3.fc14,kcm-gtk-0.5.3-7.fc14?_csrf_token=c8dec2dd8e124c801db091ac63968cfb83193741

if after tesing closes you think things dont work even though bug#591746 claims fix then this bug could be reopened but more likely should comment to bug#591746 .

ok for me now so closing this bug for now and enjoying the shiny new cursor in ff.

*** This bug has been marked as a duplicate of bug 591746 ***

Note You need to log in before you can comment on or make changes to this bug.