Bug 591822 - abrt chooses wrong suffix for sosreport tarball, uses bz2 instead of xz
abrt chooses wrong suffix for sosreport tarball, uses bz2 instead of xz
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Denys Vlasenko
Michal Nowak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 05:13 EDT by Michal Nowak
Modified: 2013-03-07 21:09 EST (History)
7 users (show)

See Also:
Fixed In Version: abrt-1.1.4-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 14:47:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (4.02 KB, patch)
2010-05-25 09:32 EDT, Denys Vlasenko
no flags Details | Diff

  None (edit)
Description Michal Nowak 2010-05-13 05:13:22 EDT
Description of problem:

This is how SOSreport is started by abrt when I attempted to report via TicketUploader:

sosreport --batch --only=anaconda --only=bootloader --only=devicemapper --only=filesys --only=hardware --only=kernel --only=libraries --only=memory --only=networking --only=nfsserver --only=pam --only=process --only=rpm -k rpm.rpmva=off --only=ssh --only=startup --only=yum

When this is run manually it results in e.g. /tmp/sosreport-dhcp-lab-222-20100513104505-a579.tar.xz (see the XZ suffix). However abrt creates file /tmp/TicketUploader-newticket-20100513081932.tar.gz with following content:

* abrt specific info regarding that crash, and
* sosreport.tar.bz2.

sosreport.tar.bz2 which is itself:

dhcp-lab-222 ~ # file ~newman/Desktop/sosreport.tar.bz2 
/home/newman/Desktop/sosreport.tar.bz2: xz compressed data

Version-Release number of selected component (if applicable):

abrt-1.1.0-1.el6.x86_64
sos-2.1-0.el6.noarch

How reproducible:

always

Steps to Reproduce:
1. Create report via TicketUploader
2. inspect type of tar.bz2 file inside tar.gz one
  
Expected results:

File in *this case* should be named sosreport.tar.xz however one never knows the suffix prio starting sosreport because sosreport chooses compression app depending on what compression apps are present: xz -> bz2.
Comment 1 Denys Vlasenko 2010-05-25 09:32:48 EDT
Created attachment 416408 [details]
Proposed patch
Comment 2 Denys Vlasenko 2010-05-25 15:08:15 EDT
Committed the fix to git
Comment 6 releng-rhel@redhat.com 2010-07-02 14:47:38 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.