Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 591935 - Unintentional suspends with laptop lid closed and external monitor attached
Summary: Unintentional suspends with laptop lid closed and external monitor attached
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-power-manager
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: Desktop QE
URL:
Whiteboard:
: 677311 (view as bug list)
Depends On:
Blocks: 599016
TreeView+ depends on / blocked
 
Reported: 2010-05-13 14:10 UTC by Michal Haško
Modified: 2017-12-06 12:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 12:25:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Michal Haško 2010-05-13 14:10:12 UTC
Description of problem:
When on docking station with external monitor attached, laptop lid closed, in "Power Management", in tab "On AC Power" the "When laptop lid is closed:" set to "Suspend" switching to virtual console and back to X session makes the computer to suspend.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.28.3-3.el6.x86_64
kernel-2.6.32-25.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Open "Power Management"
2. Select the "On AC Power" tab.
3. Set "When laptop lid is closed:" to "Suspend".
4. Switch to virtual console (e.g. Alt+F2).
5. Switch back to X session.
  
Actual results:
laptop suspends

Expected results:
should switch to the X session

Comment 1 RHEL Program Management 2010-05-13 15:19:32 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 RHEL Program Management 2010-07-15 14:23:25 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 3 Taunus 2010-12-03 13:36:27 UTC
This is still an issue with rhel 6 final. Pretty annoying one too.

Comment 4 RHEL Program Management 2011-04-04 01:50:59 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 6 Richard Hughes 2011-11-15 13:13:28 UTC
*** Bug 677311 has been marked as a duplicate of this bug. ***

Comment 8 Jan Kurik 2017-12-06 12:25:21 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.