Bug 592033 - race condition in pvclock wallclock calculation
race condition in pvclock wallclock calculation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Glauber Costa
Virtualization Bugs
:
Depends On: 592021
Blocks: 533943 Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-05-13 14:01 EDT by Glauber Costa
Modified: 2013-01-09 17:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 592021
Environment:
Last Closed: 2010-11-11 11:11:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glauber Costa 2010-05-13 14:01:39 EDT
+++ This bug was initially created as a clone of Bug #592021 +++

The hypervisor code for wallclock setting in pvclock is subject to race, since the version variable is static, and thus, shared among all guests.

This means that theoretically, one guest can mess up with the others view of version, causing it to be different among reads, which can lead to a livelock.
Comment 1 RHEL Product and Program Management 2010-05-13 15:06:40 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Aristeu Rozanski 2010-05-28 16:37:41 EDT
Patch(es) available on kernel-2.6.32-31.el6
Comment 5 Shirley Zhou 2010-08-17 03:37:01 EDT
Verify this bug with kernel-2.6.32-63.el6 as following:

1. sync time on host
ntpdate -b clock.redhat.com
2. Run 4 rhel6 guest on host with option
 -no-kvm-pit-reinjection   -rtc base=utc,clock=host,driftfix=slew
3.check time info  on each guest
ntpdate -q clock.redhat.com

There is no huge time drift happens on each guest.

So I think this bug has been fixed. change status to verified.
Comment 6 releng-rhel@redhat.com 2010-11-11 11:11:27 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.