Bug 592060 - The setting in grub on FIRSTBOOT cause failures
Summary: The setting in grub on FIRSTBOOT cause failures
Status: CLOSED DUPLICATE of bug 592080
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 19:00 UTC by Richard Freiss
Modified: 2010-05-13 21:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 21:36:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Freiss 2010-05-13 19:00:30 UTC
Description of problem:
The GRUB setting for timeout do not allow changes on firstboot.
The installer must must into rescue mode to modify grub if debug changes are needed.

Another issue is the the kernel commands entered during the install are not copied to the kernel command. 

timeout=0

Version-Release number of selected component (if applicable):


How reproducible:
Yes

Steps to Reproduce:
1. Preform an basic install on any x86_64 system
2. Attempt kernel command setting
   In my case pcie_aspm=off
3. Attempt to change the command to pcie_aspm=on on firstboot
  
Actual results:

Default timeout=0
pcie_aspm is not on the kernel comman line in /boot/grub/menu.lst

Expected results:

The setting of timeout= 5 or more by default so that the user can stop grub to make changes.

Additional info:

Example of grub setting

# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/sda3
#          initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=0
serial --unit=1 --speed=115200
terminal --timeout=5 serial console

#0
title Red Hat Enterprise Linux 6.0 Snap 2 (2.6.32-23.el6.x86_64)
        root (hd0,0)
        kernel /vmlinuz-2.6.32-23.el6.x86_64 ro root=UUID=781ef5c9-e550-485d-bba3-1a307343fb1a rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us console=ttyS1,115200N8 pcie_aspm=off crashkernel=256M
        initrd /initramfs-2.6.32-23.el6.x86_64.img

Comment 2 RHEL Product and Program Management 2010-05-13 20:19:11 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Chris Lumens 2010-05-13 21:36:11 UTC
Since we have another bug filed later but was cloned from one filed earlier just on this situation, I'm going to dupe this one to that one.

*** This bug has been marked as a duplicate of bug 592080 ***


Note You need to log in before you can comment on or make changes to this bug.