Bug 592080 - GRUB bootloader should have a few seconds delay on a multi-boot setup
GRUB bootloader should have a few seconds delay on a multi-boot setup
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
: 592060 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-13 15:51 EDT by Bill Nottingham
Modified: 2014-03-16 23:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 590661
Environment:
Last Closed: 2010-05-17 05:35:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2010-05-13 15:51:45 EDT
+++ This bug was initially created as a clone of Bug #590661 +++

Description of problem:


GRUB by default in configured in Fedora to not show the menu and have zero delay but in a multi-boot environment where Anaconda detects Windows and configures GRUB to boot Windows as a alternative, GRUB was configured by Anaconda to have a few seconds delay and show the menu so that the user can choose between Fedora and Windows. 

Unfortunately this is not the case with Fedora 13 RC2 anymore.  This results in a non-technical user unable to boot into Windows after installing Fedora 13.  I am marking it as a blocker

--- Additional comment from awilliam@redhat.com on 2010-05-10 10:38:40 EDT ---

Can anyone confirm how this behaved in F12?

--- Additional comment from metherid@gmail.com on 2010-05-10 14:17:15 EDT ---

Fedora 12 works as expected.  This is a regression.

--- Additional comment from leigh123linux@googlemail.com on 2010-05-11 05:05:44 EDT ---

This never worked in F12 for me (I multi-boot several Linux distro's).


https://bugzilla.redhat.com/show_bug.cgi?id=541315

The zero delay sucks.

--- Additional comment from leigh123linux@googlemail.com on 2010-05-11 05:06:14 EDT ---

(In reply to comment #3)
> This never worked in F12 for me (I multi-boot several Linux distro's).
> 
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=541315
> 
> The zero delay sucks.    

And it still doesn't work in F13.

--- Additional comment from pjones@redhat.com on 2010-05-11 09:45:56 EDT ---

*** Bug 574994 has been marked as a duplicate of this bug. ***

--- Additional comment from narfman0@yahoo.com on 2010-05-11 09:49:39 EDT ---

Worked for me F12 on 2/2 of my machines as Rahul explains. 0 delay does suck..!

--- Additional comment from poelstra@redhat.com on 2010-05-11 21:02:14 EDT ---

Reviewed by a QA, Release Engineering, etc. at 2010-05-11 "Go/No-Go Meeting.  Move to F13Target, will accept into F13 final a well tested fix for this issue considering the potential negative press.

--- Additional comment from updates@fedoraproject.org on 2010-05-12 15:20:53 EDT ---

anaconda-13.42-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.42-1.fc13
Comment 2 Chris Lumens 2010-05-13 17:36:11 EDT
*** Bug 592060 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2010-05-13 17:40:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Ray Strode [halfline] 2010-05-13 22:31:51 EDT
The default timeout in grub for RHEL was changed to be non-zero regardless of what other OSes are installed some time before the alpha, right?
Comment 5 Hans de Goede 2010-05-17 05:35:40 EDT
(In reply to comment #4)
> The default timeout in grub for RHEL was changed to be non-zero regardless of
> what other OSes are installed some time before the alpha, right?    

Right.

installclasses/rhel.py:

class InstallClass(BaseInstallClass):

    bootloaderTimeoutDefault = 5

But we have (had ?) some issues with product.img loading causing us to use the Fedora install class for RHEL installs, this is being tracked in another bug.

Note You need to log in before you can comment on or make changes to this bug.