Bug 592197 - [WHQL] BSOD happens during Ethernet NDISTest 6.0 testing on windows 2003
Summary: [WHQL] BSOD happens during Ethernet NDISTest 6.0 testing on windows 2003
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 08:23 UTC by Xiaoli Tian
Modified: 2010-05-20 08:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 08:47:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of BSOD (118.49 KB, image/png)
2010-05-14 08:23 UTC, Xiaoli Tian
no flags Details

Description Xiaoli Tian 2010-05-14 08:23:31 UTC
Created attachment 413972 [details]
screenshot of BSOD

Description of problem:
BSOD Occurred when running task "start ndis test client"

The dump file analysis result as following: 
Loading Dump File [C:\WINDOWS\MEMORY.DMP]

Kernel Summary Dump File: Only kernel address space is available



Symbol search path is: SRV*c:\symbols*http://msdl.microsoft.com/download/symbols

Executable search path is: 

Windows Server 2003 Kernel Version 3790 (Service Pack 2) MP (2 procs) Free x86 compatible

Product: Server, suite: Enterprise TerminalServer SingleUserTS

Built by: 3790.srv03_sp2_gdr.100216-1301

Machine Name:

Kernel base = 0x80800000 PsLoadedModuleList = 0x808a6ea8

Debug session time: Fri May 14 11:44:39.488 2010 (GMT-7)

System Uptime: 0 days 0:27:20.859

Loading Kernel Symbols

...............................................................

.................................

Loading User Symbols



Loading unloaded module list

....

*******************************************************************************

*                                                                             *

*                        Bugcheck Analysis                                    *

*                                                                             *

*******************************************************************************



Use !analyze -v to get detailed debugging information.



BugCheck 8E, {80000003, b9a3e560, 8089a41c, 0}



*** ERROR: Module load completed but symbols could not be loaded for ndistest.sys

Probably caused by : ndistest.sys ( ndistest+20560 )



Followup: MachineOwner

---------



0: kd> !analyze -v

*******************************************************************************

*                                                                             *

*                        Bugcheck Analysis                                    *

*                                                                             *

*******************************************************************************



KERNEL_MODE_EXCEPTION_NOT_HANDLED (8e)

This is a very common bugcheck.  Usually the exception address pinpoints

the driver/function that caused the problem.  Always note this address

as well as the link date of the driver/image that contains this address.

Some common problems are exception code 0x80000003.  This means a hard

coded breakpoint or assertion was hit, but this system was booted

/NODEBUG.  This is not supposed to happen as developers should never have

hardcoded breakpoints in retail code, but ...

If this happens, make sure a debugger gets connected, and the

system is booted /DEBUG.  This will let us see why this breakpoint is

happening.

Arguments:

Arg1: 80000003, The exception code that was not handled

Arg2: b9a3e560, The address that the exception occurred at

Arg3: 8089a41c, Trap Frame

Arg4: 00000000



Debugging Details:

------------------





EXCEPTION_CODE: (HRESULT) 0x80000003 (2147483651) - One or more arguments are invalid



FAULTING_IP: 

ndistest+20560

b9a3e560 cc              int     3



TRAP_FRAME:  8089a41c -- (.trap 0xffffffff8089a41c)

ErrCode = 00000000

eax=08000000 ebx=00000000 ecx=b9a4cf83 edx=0000000b esi=8089a518 edi=b9a31410

eip=b9a3e561 esp=8089a490 ebp=8089a490 iopl=0         nv up ei pl nz na pe nc

cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00000206

ndistest+0x20561:

b9a3e561 b001            mov     al,1

Resetting default scope



DEFAULT_BUCKET_ID:  INTEL_CPU_MICROCODE_ZERO



BUGCHECK_STR:  0x8E



PROCESS_NAME:  Idle



CURRENT_IRQL:  2



LAST_CONTROL_TRANSFER:  from 8082d820 to 80827c83



STACK_TEXT:  

80899fe8 8082d820 0000008e 80000003 b9a3e560 nt!KeBugCheckEx+0x1b

8089a3ac 8088a2aa 8089a3c8 00000000 8089a41c nt!KiDispatchException+0x3a2

8089a414 8088aa44 8089a490 b9a3e561 badb0d00 nt!CommonDispatchException+0x4a

8089a414 b9a3e561 8089a490 b9a3e561 badb0d00 nt!KiTrap03+0xb0

WARNING: Stack unwind information not available. Following frames may be wrong.

8089a490 b9a315a7 08000000 b9a31410 8089a518 ndistest+0x20561

8089a4e4 80831cdc 89bb60a8 89882738 82478989 ndistest+0x135a7

8089a5a8 808320b7 00000000 00000000 02019a36 nt!KiTimerExpiration+0x548

8089a600 8088de7f 00000000 0000000e 00000000 nt!KiRetireDpcList+0x65

8089a604 00000000 0000000e 00000000 00000000 nt!KiIdleLoop+0x37





STACK_COMMAND:  .bugcheck ; kb



FOLLOWUP_IP: 

ndistest+20560

b9a3e560 cc              int     3



SYMBOL_NAME:  ndistest+20560



FOLLOWUP_NAME:  MachineOwner



MODULE_NAME: ndistest



IMAGE_NAME:  ndistest.sys



DEBUG_FLR_IMAGE_TIMESTAMP:  4b081570



FAILURE_BUCKET_ID:  0x8E_VRF_ndistest+20560



BUCKET_ID:  0x8E_VRF_ndistest+20560



Followup: MachineOwner

---------



Version-Release number of selected component (if applicable):
virtio-win driver version:05/03/2010,6.0.209.605
kernel:2.6.32-19.el6,x86_64
WLK 1.5.7565.000
qemu-kvm-0.12.1.2-2.17.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Prepare WHQL testing environment
2.Start windows 2003 guest with command:
/usr/libexec/qemu-kvm -no-hpet -usbdevice tablet -rtc-td-hack -name nic1-03-32 -m 2G -smp 4 -net nic,vlan=1,macaddr=00:55:77:7a:29:f8,model=rtl8139 -net tap,vlan=1,script=/etc/qemu-ifup -net nic,vlan=2,macaddr=00:2b:e1:15:21:62,model=virtio -net tap,vlan=2,script=/etc/qemu-ifup-private -net nic,vlan=3,macaddr=00:7b:3a:86:13:92,model=virtio -net tap,vlan=3,script=/etc/qemu-ifup-private -drive file=/home/WHQL/Win2003/NIC/Win0332-NIC1.qcow2,if=ide -uuid 0455a183-b9a1-0731-af31-1a16672911c1 -vga std -vnc :3
3.Run job Ethernet NDIS-test 6.0 
  
Actual results:
BSOD happens.

Expected results:
Pass.

Additional info:
CPU information of host:
processor       : 15
vendor_id       : GenuineIntel
cpu family      : 6
model           : 26
model name      : Intel(R) Xeon(R) CPU           E5520  @ 2.27GHz
stepping        : 5
cpu MHz         : 2261.094
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 3
cpu cores       : 4
apicid          : 7
initial apicid  : 7
fpu             : yes
fpu_exception   : yes
cpuid level     : 11
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology tsc_reliable nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm dca sse4_1 sse4_2 popcnt lahf_lm ida tpr_shadow vnmi flexpriority ept vpid
bogomips        : 4521.29
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management:

Comment 2 RHEL Product and Program Management 2010-05-14 09:43:43 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Yan Vugenfirer 2010-05-14 13:08:49 UTC
Please always attach dump file or point to its location on the network.

Comment 6 Xiaoli Tian 2010-05-20 08:47:01 UTC
I have tested this job on RHEL6.0(kernel-2.6.32-24.el6.x86_64,qemu-kvm-0.12.1.2-2.51.el6.x86_64) using virtio-win driver:05/17/2010,6.0.209.605,
no BSOD,but bug 590945 still exists,I will close this bug as not a bug.


Note You need to log in before you can comment on or make changes to this bug.