Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 592249 - Packaging bug on erlang-os_mon-R13B-04.10.fc12.i686
Packaging bug on erlang-os_mon-R13B-04.10.fc12.i686
Status: CLOSED DUPLICATE of bug 592251
Product: Fedora
Classification: Fedora
Component: erlang (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-14 07:07 EDT by Nuno Nunes
Modified: 2010-05-14 08:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-14 08:05:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nuno Nunes 2010-05-14 07:07:59 EDT
While upgrading from erlang-R13B-04.6.fc12.i686 to erlang-R13B-04.10.fc12.i686 (via yum upgrade), the rabbitmq-server application stopped working. I traced it down to a bug in the erlang-os_mon-R13B-04.10.fc12.i686 package.


Version-Release number of selected component (if applicable):
erlang-R13B-04.10.fc12.i686
erlang-os_mon-R13B-04.10.fc12.i686

How reproducible:
With rabbitmq-server, erlang-R13B-04.6.fc12.i686 and the whole erlang-* family of RPMs installed, do `/etc/init.d/rabbitmq-server start` and it works.

With erlang-R13B-04.10.fc12.i686 and the associated erlang-* family of RPMs, it fails.


Steps to Reproduce:
1. yum install -a rabbitmq-server
2. /etc/init.d/rabbitmq-server start
 
Actual results:
The server doesn't start and spits out the following to the /var/log/rabbitmq/startup_log file:

{"init terminating in do_boot",{{nocatch,{error,{cannot_start_application,rabbit,{bad_return,{{rabbit,start,[normal,[]]},{'EXIT',{undef,[{nteventlog,module_info,[attributes]},{rabbit,'-boot_steps/0-fun-0-',1},{lists,flatmap,2},{lists,flatmap,2},{rabbit,boot_steps,0},{rabbit,start,2},{application_master,start_it_old,4}]}}}}}}},[{init,start_it,1},{init,start_em,1}]}}

Expected results:
The server should start running.

Additional info:
I traced it down to the lack of the nteventlog module, which is reffered to in /usr/lib/erlang/lib/os_mon-2.2.5/ebin/os_mon.app which, in turn, is provided by erlang-os_mon-R13B-04.10.fc12.i686.

I could not downgrade because only the erlang RPM itself knows how to, all the other erlang-* ones don't know how to, so this is a no-return situation (shy from uninstalling and then installing the old RPMs by hand).
Comment 1 Peter Lemenkov 2010-05-14 08:05:21 EDT

*** This bug has been marked as a duplicate of bug 592251 ***

Note You need to log in before you can comment on or make changes to this bug.