Bug 592251 - Packaging bug on erlang-os_mon-R13B-04.10.fc12.i686
Packaging bug on erlang-os_mon-R13B-04.10.fc12.i686
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: erlang (Show other bugs)
12
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
: 592249 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-14 07:13 EDT by Nuno Nunes
Modified: 2010-05-15 16:41 EDT (History)
3 users (show)

See Also:
Fixed In Version: erlang-R13B-04.11.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-15 16:29:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nuno Nunes 2010-05-14 07:13:48 EDT
While upgrading from erlang-R13B-04.6.fc12.i686 to erlang-R13B-04.10.fc12.i686 (via yum upgrade), the rabbitmq-server application stopped working. I traced it down to a bug in the erlang-os_mon-R13B-04.10.fc12.i686 package.


Version-Release number of selected component (if applicable):
erlang-R13B-04.10.fc12.i686
erlang-os_mon-R13B-04.10.fc12.i686

How reproducible:
With rabbitmq-server, erlang-R13B-04.6.fc12.i686 and the whole erlang-* family of RPMs installed, do `/etc/init.d/rabbitmq-server start` and it works.

With erlang-R13B-04.10.fc12.i686 and the associated erlang-* family of RPMs, it fails.


Steps to Reproduce:
1. yum install -a rabbitmq-server
2. /etc/init.d/rabbitmq-server start
 
Actual results:
The server doesn't start and spits out the following to the /var/log/rabbitmq/startup_log file:

{"init terminating in do_boot",{{nocatch,{error,{cannot_start_application,rabbit,{bad_return,{{rabbit,start,[normal,[]]},{'EXIT',{undef,[{nteventlog,module_info,[attributes]},{rabbit,'-boot_steps/0-fun-0-',1},{lists,flatmap,2},{lists,flatmap,2},{rabbit,boot_steps,0},{rabbit,start,2},{application_master,start_it_old,4}]}}}}}}},[{init,start_it,1},{init,start_em,1}]}}

Expected results:
The server should start running.

Additional info:
I traced it down to the lack of the nteventlog module, which is reffered to in /usr/lib/erlang/lib/os_mon-2.2.5/ebin/os_mon.app which, in turn, is provided by erlang-os_mon-R13B-04.10.fc12.i686.

I could not downgrade because only the erlang RPM itself knows how to, all the other erlang-* ones don't know how to, so this is a no-return situation (shy from uninstalling and then installing the old RPMs by hand).
Comment 1 Peter Lemenkov 2010-05-14 07:19:17 EDT
I will take care of this issue.
Comment 2 Peter Lemenkov 2010-05-14 07:40:10 EDT
As a quick solution, I advice you to manually edit /usr/{lib,lib64}/erlang/lib/os_mon-2.2.5/ebin/os_mon.app in the following way:

--- /usr/lib/erlang/lib/os_mon-2.2.5/ebin/os_mon.app.orig	2010-05-14 15:38:49.000000000 +0400
+++ /usr/lib/erlang/lib/os_mon-2.2.5/ebin/os_mon.app	2010-05-14 15:38:58.000000000 +0400
@@ -21,7 +21,7 @@
    [{description, "CPO  CXC 138 46"},
     {vsn, "2.2.5"},
     {modules, [os_mon, os_mon_mib, os_sup,
-               disksup, memsup, cpu_sup, os_mon_sysinfo, nteventlog]},
+               disksup, memsup, cpu_sup, os_mon_sysinfo]},
     {registered, [os_mon_sup, os_mon_sysinfo, disksup, memsup, cpu_sup, 
                   os_sup_server]},
     {applications, [kernel, stdlib, sasl]},
[root@Sulaco ~]#
---
I will provide new build shortly.
Comment 3 Peter Lemenkov 2010-05-14 08:05:21 EDT
*** Bug 592249 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2010-05-14 10:40:35 EDT
erlang-R13B-04.11.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/erlang-R13B-04.11.fc13
Comment 5 Fedora Update System 2010-05-14 10:40:40 EDT
erlang-R13B-04.11.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/erlang-R13B-04.11.fc12
Comment 6 Fedora Update System 2010-05-15 16:29:04 EDT
erlang-R13B-04.11.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-05-15 16:41:48 EDT
erlang-R13B-04.11.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.