This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 592294 - grubby segfaults when default kernel is Fedora
grubby segfaults when default kernel is Fedora
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grubby (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
: 599962 625306 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-14 09:41 EDT by Ian Pilcher
Modified: 2011-02-01 08:39 EST (History)
7 users (show)

See Also:
Fixed In Version: grubby-7.0.15-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:36:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
grub.conf (1.53 KB, text/plain)
2010-05-14 09:42 EDT, Ian Pilcher
no flags Details

  None (edit)
Description Ian Pilcher 2010-05-14 09:41:22 EDT
Description of problem:
I have RHEL 6 beta installed alongside Fedora 12.  The default stanza in
grub.conf is the latest Fedora 12 kernel (see attached grub.conf).  This
is causing grubby to segfault:

[root@localhost ~]# grubby --default-kernel
grubby recieved SIGSEGV!  Backtrace (7):
grubby[0x40800f]
/lib64/libc.so.6[0x3ef0c32a40]
/lib64/libc.so.6[0x3ef0d2799a]
grubby[0x40695e]
grubby[0x407b56]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x3ef0c1ec5d]
grubby[0x401709]

I tried installing the relevant debuginfo packages and getting a back-
trace, but I didn't get anything useful:

[root@localhost ~]# gdb /sbin/grubby
GNU gdb (GDB) Red Hat Enterprise Linux (7.1-18.el6)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /sbin/grubby...Reading symbols from /usr/lib/debug/sbin/grubby.debug...done.
done.
(gdb) set args --default-kernel
(gdb) run
Starting program: /sbin/grubby --default-kernel

Program received signal SIGSEGV, Segmentation fault.
__strcmp_ssse3 () at ../sysdeps/x86_64/strcmp.S:107
107		movlpd	(%rsi), %xmm2
(gdb) bt
#0  __strcmp_ssse3 () at ../sysdeps/x86_64/strcmp.S:107
#1  0x000000000040695e in suitableImage (entry=<value optimized out>, bootPrefix=<value optimized out>, 
    skipRemoved=<value optimized out>, flags=<value optimized out>) at grubby.c:1297
#2  0x0000000000407b56 in main (argc=<value optimized out>, argv=<value optimized out>) at grubby.c:3168

If I edit grub.conf and set the default to the RHEL 6 stanza, grubby
works:

[root@localhost ~]# grubby --default-kernel
/boot/vmlinuz-2.6.32-19.el6.x86_64

Version-Release number of selected component (if applicable):
grubby-7.0.15-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  Install attached grub.conf
2.  Run "grubby --default-kernel"
  
Actual results:
segfault

Expected results:
Should return /boot/vmlinuz-2.6.32.11-99.fc12.x86_64

Additional info:
Comment 1 Ian Pilcher 2010-05-14 09:42:46 EDT
Created attachment 414051 [details]
grub.conf
Comment 3 RHEL Product and Program Management 2010-05-14 11:55:04 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Brian Lane 2010-06-07 18:59:37 EDT
*** Bug 599962 has been marked as a duplicate of this bug. ***
Comment 6 Alexander Todorov 2010-07-20 11:03:42 EDT
Tested with snap #8 (0715.0) - a system where both Fedora and RHEL6 are installed .I can boot into both OSes without traceback. When making Fedora the default boot is happy. Moving to VERIFIED.
Comment 7 Brian Lane 2010-08-19 15:12:25 EDT
*** Bug 625306 has been marked as a duplicate of this bug. ***
Comment 10 releng-rhel@redhat.com 2010-11-10 15:36:26 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.