Bug 599962 - segfault in grubby
segfault in grubby
Status: CLOSED DUPLICATE of bug 592294
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 17:07 EDT by Neal Becker
Modified: 2010-06-07 18:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 18:59:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anacond.log (9.44 KB, text/plain)
2010-06-03 17:08 EDT, Neal Becker
no flags Details
upgrade.log (92.61 KB, text/plain)
2010-06-03 17:09 EDT, Neal Becker
no flags Details
grub.conf (661 bytes, text/plain)
2010-06-03 17:10 EDT, Neal Becker
no flags Details

  None (edit)
Description Neal Becker 2010-06-03 17:07:57 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Neal Becker 2010-06-03 17:08:50 EDT
Created attachment 420666 [details]
anacond.log
Comment 2 Neal Becker 2010-06-03 17:09:27 EDT
Created attachment 420685 [details]
upgrade.log
Comment 3 Neal Becker 2010-06-03 17:10:01 EDT
Created attachment 420702 [details]
grub.conf
Comment 4 Neal Becker 2010-06-03 17:10:47 EDT
rpm -q kernel grubby
kernel-2.6.33.5-112.fc13.x86_64
grubby-7.0.13-1.fc13.x86_64
Comment 5 Brian Lane 2010-06-03 19:07:21 EDT
Relevant part of the log is the backtrace:

grubby recieved SIGSEGV!  Backtrace (9):
/sbin/grubby[0x40805f]
/lib64/libc.so.6(+0x32a40)[0x7f031b820a40]
/lib64/libc.so.6(+0x1279ba)[0x7f031b9159ba]
/sbin/grubby[0x40695e]
/sbin/grubby[0x406b10]
/sbin/grubby[0x406d6d]
/sbin/grubby[0x407ec5]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x7f031b80cc5d]
/sbin/grubby[0x401709]

This may be related to the suitableImage() bug I just fixed.
Comment 6 Brian Lane 2010-06-03 19:10:40 EDT
The grub.conf you posted is from a f13 system. Do you still have the f12 version that failed?
Comment 7 Neal Becker 2010-06-03 19:28:48 EDT
No, but all I changed is edit the version numbers.
Comment 8 Brian Lane 2010-06-07 18:59:37 EDT

*** This bug has been marked as a duplicate of bug 592294 ***

Note You need to log in before you can comment on or make changes to this bug.