Bug 592358 - Document behavior if --cluster-size is specified.
Summary: Document behavior if --cluster-size is specified.
Status: CLOSED DUPLICATE of bug 598653
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Programming_Reference   
(Show other bugs)
Version: beta
Hardware: All
OS: Linux
medium
medium
Target Milestone: 1.3
: ---
Assignee: Jonathan Robie
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 16:02 UTC by Alan Conway
Modified: 2013-08-06 00:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-01 19:32:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Conway 2010-05-14 16:02:40 UTC
The documentation needs to cover this:

If --cluster-size=N is specified then the cluster will not become active until it has N members. This is useful if your cluster members have persistent stores, since it allows all the members to compare the status and select the correct store image to start up with.

If a client connects to the cluster while there are < N members, the client will hang opening the connection until all N members have joined the cluster, then it will proceed as normal. 

If connection heartbeats are enabled they can interrupt this hang XREF to heartbeats

Comment 1 ppecka 2010-05-17 15:03:09 UTC
please check https://bugzilla.redhat.com/show_bug.cgi?id=592995 also

Comment 2 Alan Conway 2010-06-01 19:32:39 UTC

*** This bug has been marked as a duplicate of bug 598653 ***


Note You need to log in before you can comment on or make changes to this bug.