Bug 59276 - DS10, ES40, ES45 can't enable DMA on IDE CD
Summary: DS10, ES40, ES45 can't enable DMA on IDE CD
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Beth Uptagrafft
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 58719 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-04 15:32 UTC by Jeff Wiedemeier
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-08 20:53:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Wiedemeier 2002-02-04 15:32:36 UTC
Description of Problem:

Can't enable DMA on CD-ROM (IDE) on AlphaServer DS10, AlphaServer DS10L,
AlphaServer ES40, AlphaServer ES45.

Version-Release number of selected component (if applicable):

kernel 2.4.9-14a

How Reproducible:

always

Steps to Reproduce:
1. during boot, note ALi15x3: simplex device messages
2. after booting, try hdparm -d 1 /dev/hda (assuming CD is hda)
3. hdparm fails to set dma

Actual Results:

Can't turn on DMA

Expected Results:

DMA turned on

Additional Information:
	
This is caused by the lack of the ali15x3 driver in the kernel. The generic PCI
IDA dma driver does not deal with the ALi1543 on these systems correctly. The
correct driver is needed. 

To fix - enable "ALI M15x3 chipset support" under "IDE, ATI, and ATAPI Block
devices" in the kernel configuration.

Comment 1 Beth Uptagrafft 2002-02-08 20:53:09 UTC
*** Bug 58719 has been marked as a duplicate of this bug. ***

Comment 2 Phil Copeland 2002-04-03 08:08:48 UTC
Fixed for final (woking)


Note You need to log in before you can comment on or make changes to this bug.