This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 592852 - [abrt] crash in evolution-2.28.3-3.el6: raise: Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
[abrt] crash in evolution-2.28.3-3.el6: raise: Process /usr/bin/evolution was...
Status: NEW
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gtk2 (Show other bugs)
6.0
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Benjamin Otte
Desktop QE
abrt_hash:4158944342d0ebde1f13de73405...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-17 03:51 EDT by Lubos Kocman
Modified: 2016-05-02 06:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (76.50 KB, text/plain)
2010-05-17 03:51 EDT, Lubos Kocman
no flags Details

  None (edit)
Description Lubos Kocman 2010-05-17 03:51:52 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: evolution
comment: Evolution is configured for imap/smtp in redhat
component: evolution
crash_function: raise
executable: /usr/bin/evolution
global_uuid: 4158944342d0ebde1f13de7340523f84d061a98d
kernel: 2.6.32-25.el6.i686
package: evolution-2.28.3-3.el6
rating: 4
reason: Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
release: Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)

How to reproduce
-----
1. Log off from gnome with evolution running
2. Log in to gnome (evolution is in start up applications on login)
3. Evolution crashed
Comment 1 Lubos Kocman 2010-05-17 03:51:54 EDT
Created attachment 414471 [details]
File: backtrace
Comment 3 Milan Crha 2010-05-17 06:23:36 EDT
Thanks for a bug report. This is same as bug #544759 for Fedora, which was marked as a duplicate and that one moved to an upstream bug [1], which was unfortunately closed as invalid. Anyway, looking around for XAllocID bugs I found at least these [2] where subject contains "XAllocID". From that I would assume it's something with gtk2, as stated in bug #559199 comment #3.

I saw something similar upstream too, which was caused by evolution-mapi, calling g_free on something allocated with g_slice or g_slice_free called on a g_new0 memory, I do not recall precisely, but you are mentioning above you are using only IMAP, thus that shouldn't be the case.

Thus I'm moving this to gtk2.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=601986

[2] https://bugzilla.redhat.com/buglist.cgi?query_format=advanced&short_desc=XAlloc&bug_status=NEW&bug_status=ASSIGNED&bug_status=CLOSED&short_desc_type=allwordssubstr&product=Fedora&classification=Fedora
Comment 4 Lubos Kocman 2010-05-17 07:02:46 EDT
Hello, yes I use only imap.
Comment 5 RHEL Product and Program Management 2010-06-07 12:03:50 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 RHEL Product and Program Management 2010-07-15 10:29:14 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 11 RHEL Product and Program Management 2011-07-05 20:28:42 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 14 RHEL Product and Program Management 2013-10-14 01:24:16 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.