Bug 592921 - ibm-prtm package needs to be updated
Summary: ibm-prtm package needs to be updated
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-utilities (Show other bugs)
(Show other bugs)
Version: Development
Hardware: x86_64 All
low
high
Target Milestone: 1.3
: ---
Assignee: Clark Williams
QA Contact: David Sommerseth
URL:
Whiteboard:
Keywords:
: 578772 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-17 11:40 UTC by IBM Bug Proxy
Modified: 2016-05-22 23:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The ibm-prtm package has been updated to check for the Intelligent Platform Management Interface (IPMI) at runtime.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-11 15:10:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0762 normal SHIPPED_LIVE Red Hat Enterprise MRG Realtime bug fix and enhancement update 2010-10-11 15:10:12 UTC
IBM Linux Technology Center 63812 None None None Never

Description IBM Bug Proxy 2010-05-17 11:40:48 UTC
=Comment: #0=================================================
Vernon Mauery <vernux@us.ibm.com> - 
The latest ibm-prtm package has been released on its sourceforge page: 
https://sourceforge.net/projects/ibm-prtm/

Version 1.7 supports the new platforms that were added with the latest i7core_edac driver that was
recently pushed.

Major changes in 1.7 that might be of notice:
1) The init script is now LSB compliant so it should be able to be used AS-IS on all LSB compliant
distros.
2) Point 1 includes taking out the ipmi init code that used to be in the script and replacing it
with a dependency on ipmidrv in the INIT INFO section
3) the init script has been changed to expect that the daemon script lives in /usr/sbin instead of
/sbin, since that makes more sense.  The Makefile has been changed to suit (in case anybody uses that).

Please pull this in as the latest ibm-prtm package.

Comment 1 IBM Bug Proxy 2010-05-24 20:41:23 UTC
------- Comment From vernux@us.ibm.com 2010-05-24 16:32 EDT-------
Notes from the weekly call:

1) ibm-prtmd moved from /sbin to /usr/sbin, so packaging needs to be aware of that.
2) ibm-prtm script depends on ipmi, so package needs to depend on OpenIPMI-tools.

Comment 2 Clark Williams 2010-07-19 20:44:45 UTC
ibm-prtm-1.7-2 has been built in brew and is in testing now.

Comment 3 IBM Bug Proxy 2010-07-22 14:41:53 UTC
------- Comment From vernux@us.ibm.com 2010-07-22 10:37 EDT-------
*** Bug 62094 has been marked as a duplicate of this bug. ***

Comment 4 IBM Bug Proxy 2010-08-02 15:51:59 UTC
------- Comment From vernux@us.ibm.com 2010-08-02 11:45 EDT-------
I must have missed the dependency because I don't see it listed in what I specified below, but ibm-prtm package needs to depend on OpenIPMI too.  This is the package that provides /etc/init.d/ipmi which loads the ipmi drivers needed by ipmitool to talk to the BMC.

Also, I am not sure how this works, but we need to make sure that the ipmi init script is enabled too.  I thought that is what the LSB headers of Requires and Provides are supposed to do, but apparently not.  So we need to add a 'chkconfig ipmi on' to the post-install script or something.

So to sum up:
1) add rpm dependency for OpenIPMI package
2) enable ipmi init script on install

Comment 5 John Kacur 2010-08-25 15:37:59 UTC
*** Bug 578772 has been marked as a duplicate of this bug. ***

Comment 6 Clark Williams 2010-09-28 19:04:28 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
* Cause: ibm-prtm package needed to be update to handle new hardware models
* Consequence: some blades and rackmount models didn't mitigate SMIs properly
* Fix: update to latest ibm-prtm package from IBM
* Result: better realtime performance for affected models

Comment 8 David Sommerseth 2010-10-07 16:11:47 UTC
Verified by smoketesting on ls21-2.farm.hsv.redhat.com.

[root@ls21-2 ~]# service ibm-prtm start
Starting IBM Premium Real-Time Daemon:                     [  OK  ]
[root@ls21-2 ~]# tail /var/log/messages
Oct  7 11:10:07 ls21-2 IBM Premium Real-Time Daemon: System Management Interrupts have been disabled to
Oct  7 11:10:07 ls21-2 IBM Premium Real-Time Daemon: allow this system to run in Real-Time Mode.

[root@ls21-2 ~]# service ibm-prtm stop
Stopping IBM Premium Real-Time Daemon:                     [  OK  ]
[root@ls21-2 ~]# tail /var/log/messages
Oct  7 11:10:40 ls21-2 IBM Premium Real-Time Daemon: Thermal policies (ie. acoustic mode) which were enabled on
Oct  7 11:10:40 ls21-2 IBM Premium Real-Time Daemon: systems running in Real-Time Mode may not be accepted.
Oct  7 11:10:40 ls21-2 IBM Premium Real-Time Daemon: Please set thermal policies on this system again if desired.
Oct  7 11:10:40 ls21-2 IBM ECC Detection Service: Shutting down

[root@ls21-2 ~]# rpm -q ibm-prtm
ibm-prtm-1.8-1.el5rt

Comment 9 Jaromir Hradilek 2010-10-11 14:20:21 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1 @@
-* Cause: ibm-prtm package needed to be update to handle new hardware models
+The ibm-prtm package has been updated to check for the Intelligent Platform Management Interface (IPMI) at runtime.-* Consequence: some blades and rackmount models didn't mitigate SMIs properly
-* Fix: update to latest ibm-prtm package from IBM
-* Result: better realtime performance for affected models

Comment 10 errata-xmlrpc 2010-10-11 15:10:34 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0762.html


Note You need to log in before you can comment on or make changes to this bug.