Bug 593017 - Coolkey not recognizing DoD CACs on Gemalto TOPDLGX4 144K cards.
Summary: Coolkey not recognizing DoD CACs on Gemalto TOPDLGX4 144K cards.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: coolkey
Version: 5.6
Hardware: All
OS: All
high
high
Target Milestone: beta
: ---
Assignee: Bob Relyea
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
: 610656 (view as bug list)
Depends On:
Blocks: 554476
TreeView+ depends on / blocked
 
Reported: 2010-05-17 15:50 UTC by Jeremy West
Modified: 2018-11-14 21:00 UTC (History)
33 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
The coolkey device driver has been updated to follow the new Card Compatibility Container (CCC) specification, so that Gemalto TOPDLGX4 144K CAC cards are now supported.
Clone Of: 534172
: 622916 (view as bug list)
Environment:
Last Closed: 2011-01-14 00:06:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0111 0 normal SHIPPED_LIVE coolkey enhancement update 2011-01-12 17:29:07 UTC

Comment 1 Bob Relyea 2010-07-01 23:33:11 UTC
I just realized this is the same as bug 534172, which I do have patches for. The real question is will QA want to take them.


bob

Comment 3 Bob Relyea 2010-07-22 00:39:56 UTC
 http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2617151
 package coolkey-1.1.0-15.el5

Comment 6 Issue Tracker 2010-08-11 16:08:23 UTC
Event posted on 08-11-2010 12:08pm EDT by willg

This hotfix worked for the customer and they closed the CRM. They were very
pleased. I am closing this IT. Thank you everyone!

William


This event sent from IssueTracker by willg 
 issue 964593

Comment 8 S. Kress 2010-08-30 15:24:34 UTC
Is there a way to get access to the hotfix before it hits GA?

As more of my users are issued new DOD CACs this is becoming a larger problem.

Thank you in advance,

Seth.

Comment 10 Asha Akkiangady 2010-10-21 20:16:58 UTC
Tested with a TOPDLGX4 144K smart card.

- On a Rhel 5.6 desktop installed coolkey-1.1.0-15.el5.
- used a omnikey cardman 3121 (ccid) reader
- configured the rhel 5.6 machine to do smartcard login. loaded up the root certs
  onto both /etc/pki/nssdb and firefox db
- ESC application is able to recognize the card insertion and removal
- ESC application - view certificates shows that the certs are all verified
- firefox is able to view the certs.
- Used the card to perform smart card login. Success.
- enabled screen lock upon card removal. success.
- gdm unlocks the screen once the card is inserted and enter the correct pin.
- gdm greeter recognizes insertion/removal screens successfully.

Marking this bug verified.

Comment 11 Jaromir Hradilek 2010-10-23 14:19:36 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The coolkey device driver has been updated to follow the new Card Compatibility Container (CCC) specification, so that Gemalto TOPDLGX4 144K CAC cards are now supported.

Comment 13 errata-xmlrpc 2011-01-14 00:06:36 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0111.html

Comment 14 Sadique Puthen 2011-04-25 13:43:35 UTC
*** Bug 610656 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.