Bug 593180 - Small tweak. "--only-use=" parameter not documented for "ignoredisk" option in kickstart section
Summary: Small tweak. "--only-use=" parameter not documented for "ignoredisk" option ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ruediger Landmann
QA Contact: ecs-bugs
URL:
Whiteboard:
Keywords: Documentation
: 601968 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 05:11 UTC by Justin Clift
Modified: 2010-11-11 15:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 15:33:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Clift 2010-05-18 05:11:48 UTC
Description of problem:

In section "24.4. Kickstart Options" of the RHEL 6 beta (April 2010) Installation Guide, it has "ignoredisk" documented as:

***

  ignoredisk (optional)
    Causes the installer to ignore the specified disks. This is useful if you
    use autopartition and want to be sure that some disks are ignored. For
    example, without ignoredisk, attempting to deploy on a SAN-cluster the
    kickstart would fail, as the installer detects passive paths to the SAN
    that return no partition table.

    The ignoredisk option is also useful if you have multiple paths to your
    disks.
    The syntax is:


    ignoredisk --drives=drive1,drive2,...

    where driveN is one of sda, sdb,..., hda,... etc.

***

It seems to be missing the "--only-use=xxx" parameter, generated at least by the Anaconda when RHEL 6 (beta) x86_64 is installed.

For example, after manually installing RHEL 6 beta (x86_64) in a VM here, the automatically generated kickstart script in the root directory contains:

  ignoredisk --only-use=vda

 
Actual results:

As above.


Expected results:

The --only-use parameter to be documented.

Comment 2 RHEL Product and Program Management 2010-06-07 15:54:51 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Ruediger Landmann 2010-06-21 03:46:57 UTC
*** Bug 601968 has been marked as a duplicate of this bug. ***

Comment 4 Ruediger Landmann 2010-06-21 03:48:10 UTC
Fixed in build 0-62 -- many thanks Justin :)

Comment 5 Michael Doyle 2010-07-05 02:15:48 UTC
Verified it is in Red_Hat_Enterprise_Linux-Installation_Guide-6-en-US-0-74.

--only-use — specifies a list of disks for the installer to use. All other disks are ignored. For example, to use disk sda during installation and ignore all other disks:

      ignoredisk --only-use=sda

Comment 6 releng-rhel@redhat.com 2010-11-11 15:33:46 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.