Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 593220 - On i855GM, Xv freezes screen
On i855GM, Xv freezes screen
Status: CLOSED DUPLICATE of bug 591575
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
: 624891 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 04:33 EDT by Peter Hjalmarsson
Modified: 2018-04-11 09:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-17 12:21:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg of crash (40.93 KB, text/plain)
2010-05-18 04:33 EDT, Peter Hjalmarsson
no flags Details
xorg.log of crash (67.55 KB, text/plain)
2010-05-18 04:34 EDT, Peter Hjalmarsson
no flags Details
Syslog of kernel warnings resulting from playing a video (35.62 KB, text/plain)
2010-05-29 21:09 EDT, Ian Collier
no flags Details

  None (edit)
Description Peter Hjalmarsson 2010-05-18 04:33:55 EDT
Created attachment 414774 [details]
dmesg of crash

Description of problem:
After updating to F-13 Alpha I got Xv available on my laptop and seemed to work fine.
Then I did not use my laptop much for some weeks, came back, updated it and afterwards trying to play anything on my laptop freezes the picture of X. I can VT-switch, I can close application, the pointer can move and changes depending on what it is supposed to hover over.

Version-Release number of selected component (if applicable):
Linux fleety.dodi 2.6.33.4-95.fc13.i686 #1 SMP Thu May 13 05:55:24 UTC 2010 i686 i686 i386 GNU/Linux
xorg-x11-drv-intel.i686            2.11.0-4.fc13                @fedora         
xorg-x11-server-Xorg.i686          1.8.0-12.fc13                @fedora         
xorg-x11-server-common.i686        1.8.0-12.fc13                @fedora         

How reproducible:
Try play anything in totem.

mplayer -vo xv <filename>
crashes everytime

mplayer -vo gl2 <filename>
mplayer -vo x11 <filename>
both works fine
Comment 1 Peter Hjalmarsson 2010-05-18 04:34:29 EDT
Created attachment 414776 [details]
xorg.log of crash
Comment 2 Peter Hjalmarsson 2010-05-18 04:35:30 EDT
/crash/screen freeze/

As I said the computer works fine, the only thing frozen is the X display, VT works fine and everything.
Comment 3 Peter Hjalmarsson 2010-05-27 10:40:08 EDT
Forgot to say the interesting part from dmesg is probably:
[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
render error detected, EIR: 0x00000000
[drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 875819 at 875818)

And from Xorg.0.log:

[  4160.211] (EE) intel(0): Failed to submit batch buffer, expect rendering corruption or even a frozen display: Input/output error.
[  4195.106] (WW) intel(0): i830_uxa_prepare_access: gtt bo map failed: Input/output error

My smolt profile: http://www.smolts.org/client/show/pub_34cbbbfc-2158-4b2a-8d74-04731ea37bd6

This machine is not really a production machine, and I am more then willing to help with gathering information or test stuff to see if we can make this work.
Comment 4 Matěj Cepl 2010-05-28 18:13:15 EDT
ACPI: Video Device [VID] (multi-head: yes  rom: no  post: no)
[Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.
[drm] Initialized drm 1.1.0 20060810
i915 0000:00:02.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
i915 0000:00:02.0: setting latency timer to 64
[drm] set up 0M of stolen space
[drm] initialized overlay support
...
[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
render error detected, EIR: 0x00000000
[drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 875819 at 875818)
Comment 5 Ian Collier 2010-05-29 21:09:06 EDT
Created attachment 417948 [details]
Syslog of kernel warnings resulting from playing a video

In the released Fedora 13 I experience something similar but worse.  I have:
Intel 855GM [8086:3582]
kernel-2.6.33.4-95.fc13.i686
xorg-x11-drv-intel-2.11.0-4.fc13.i686

When I play a video with "mplayer -vo xv" I get:
- a blue rectangle on the screen instead of the video
- a constant stream of "X11 error: BadAlloc (insufficient resources for operation)" messages from mplayer
- the attached kernel messages
- a hosed X server which requires a reboot to fix.

Symptoms of the latter include: display not updating properly, windows failing to clear their own backgrounds, windows failing to disappear properly when closed, system hang on the way down if I try to hibernate (usually it crashes o the way back up), system hang on the way up if I have successfully suspended the system and try to wake it up.  I can switch VTs and the text console works, but if I switch back to the X console then the corrupted display returns.

Just once I managed to play a video without any of these symptoms; after that I could play anything I liked until the next reboot, at which point the symptoms returned.  I have tried it four or five times since then and each one required a reboot.
Comment 6 Matěj Cepl 2011-01-17 12:19:56 EST
*** Bug 624891 has been marked as a duplicate of this bug. ***
Comment 7 Matěj Cepl 2011-01-17 12:21:37 EST

*** This bug has been marked as a duplicate of bug 591575 ***

Note You need to log in before you can comment on or make changes to this bug.