Bug 593235 - Drop the redhat-lsb dependency
Drop the redhat-lsb dependency
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mumble (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Osowski
Fedora Extras Quality Assurance
:
: 593238 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-18 05:29 EDT by Rahul Sundaram
Modified: 2011-03-30 16:05 EDT (History)
4 users (show)

See Also:
Fixed In Version: mumble-1.2.2-10.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-27 03:47:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2010-05-18 05:29:15 EDT
Description of problem:

You didn't respond to

http://lists.fedoraproject.org/pipermail/devel/2010-May/136329.html

The redhat-lsb package should never be added as a dependency to any package. 

You should fix the initscript to follow the packaging guidelines

https://fedorahosted.org/fesco/ticket/347

https://fedoraproject.org/wiki/Packaging:SysVInitScript
Comment 1 Kevin Kofler 2010-05-21 01:46:48 EDT
Also note that the mere presence of an LSB header on the initscript does not 
make the initscript require redhat-lsb. If you're using actual functions 
from LSB, you should be using native functions from our initscript package 
instead where applicable, or just not use those functions.

And finally, please also note that shipping a valid Fedora initscript is the 
responsibility of the packager, just shipping whatever upstream provides 
will NOT cut it in most cases.
Comment 2 Bug Zapper 2010-07-30 07:39:23 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Michael Cronenworth 2010-07-31 20:57:06 EDT
*** Bug 593238 has been marked as a duplicate of this bug. ***
Comment 4 Kevin Kofler 2010-08-02 23:13:42 EDT
Ping? This is a critical packaging guidelines violation and as such should be addressed in a timely manner. 2+ months is NOT timely!
Comment 5 Andreas Osowski 2010-08-03 23:42:31 EDT
I have pushed an updated version to devel,
Could you please confirm compliance with the guidelines?
Once you've done so, I shall update the other releases.

And sorry again for the problem :(
Comment 6 Fedora Update System 2010-08-25 14:55:14 EDT
mumble-1.2.2-10.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/mumble-1.2.2-10.fc14
Comment 7 Fedora Update System 2010-08-25 22:13:39 EDT
mumble-1.2.2-10.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mumble'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mumble-1.2.2-10.fc14
Comment 8 Fedora Update System 2011-03-30 16:04:58 EDT
mumble-1.2.2-10.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.