Bug 593238 - Please drop dependency on redhat-lsb
Summary: Please drop dependency on redhat-lsb
Status: CLOSED DUPLICATE of bug 593235
Alias: None
Product: Fedora
Classification: Fedora
Component: mumble   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Osowski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 567094
TreeView+ depends on / blocked
 
Reported: 2010-05-18 09:38 UTC by Chen Lei
Modified: 2010-08-01 00:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-01 00:57:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chen Lei 2010-05-18 09:38:04 UTC
Description of problem:

redhat-lsb on F12 will pull in huge uncessrary dependency
Also, all initscripts on fedora should use /etc/rc.d/init.d/functions rather than /lib/lsb/init-functions.


Version-Release number of selected component (if applicable):
All

How reproducible:

mock -r fedora-12-i386
/usr/sbin/mock-helper yum --installroot /var/lib/mock/fedora-12-i386/root install redhat-lsb

You'll see redhat-lsb will pull in huge dependency.

Additional info:

murmur need a rewritten to use functions in /etc/rc.d/init.d/functions 

See http://fedoraproject.org/wiki/Packaging:SysVInitScript

Comment 1 Bug Zapper 2010-07-30 11:39:28 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Michael Cronenworth 2010-08-01 00:57:06 UTC

*** This bug has been marked as a duplicate of bug 593235 ***


Note You need to log in before you can comment on or make changes to this bug.