Bug 593378 - If maps include both file and nis maps, included nis maps which worked on RHEL 5.3 no longer work on RHEL 5.4
Summary: If maps include both file and nis maps, included nis maps which worked on RHE...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs
Version: 5.4
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: Petr Beňas
URL:
Whiteboard:
Depends On:
Blocks: 594565 642612 707606
TreeView+ depends on / blocked
 
Reported: 2010-05-18 16:46 UTC by Sachin Prabhu
Modified: 2018-10-27 16:06 UTC (History)
5 users (show)

Fixed In Version: autofs-5.0.1-0.rc2.144.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 594565 (view as bug list)
Environment:
Last Closed: 2011-07-21 08:40:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch - fix negative cache included map lookup (1.16 KB, patch)
2010-05-19 07:47 UTC, Ian Kent
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1079 0 normal SHIPPED_LIVE autofs bug fix and enhancement update 2011-07-21 08:37:25 UTC

Description Sachin Prabhu 2010-05-18 16:46:52 UTC
Reproducer:

auto.master contains:

/data  /etc/auto.data

/etc/auto.data contains:

+/etc/maps/auto.data
+auto.data

Included map /etc/maps/auto.data contains:

datamount_local	-rw,soft,intr	10.33.1.41:/exports/datamount_local

Included nis map auto.data contains:

# ypcat auto.data
-rw,soft,intr 10.33.1.41:/exports/datamount_nis


autofs will correctly mount /data/datamount_local which it picks from the map /etc/maps/auto.data. However it will not mount /data/datamount_nis listed in the nis maps. 

# cd /data/datamount_local
# cd /data/datamount_nis
-bash: cd: /data/datamount_nis: No such file or directory

/data/datamount_nis will mount correctly from the nis map if the included /etc/maps/auto.data is commented out.

If instead of the nis map, another file based map is included, the auto mounts work as expected.

This is a regression since this functionality worked fine on 
autofs-5.0.1-0.rc2.102.x86_64.rpm

The following versions display this problem
autofs-5.0.1-0.rc2.131.el5
autofs-5.0.1-0.rc2.143.el5

Comment 2 Ian Kent 2010-05-19 04:10:08 UTC
Using the information in comment #0 this issue was easily
duplicated.

I believe it is due to changes made to fix the negative
caching of non-existent map keys.

Comment 3 Ian Kent 2010-05-19 07:47:33 UTC
Created attachment 415043 [details]
Patch - fix negative cache included map lookup

Comment 4 Ian Kent 2010-05-19 07:51:53 UTC
A test build which includes the above patch has been done.
It is located at:
http://people.redhat.com/~ikent/autofs-5.0.1-0.rc2.143.bz593378.1.el5

Please test this package and report results.

Comment 6 Ian Kent 2010-05-20 12:13:53 UTC
I can't identify any side effects from this change.
I've run our regression tests against the change for i386 and
x86_64 only without any unexplained fails. I've also added a
test based on the reproducer in comment #0.

So the bug has been placed in MODIFIED state.

Comment 18 Petr Beňas 2011-04-20 14:28:30 UTC
Reproduced in autofs-5.0.1-0.rc2.131.el5 and verified in autofs-5.0.1-0.rc2.144.el5.

Comment 19 errata-xmlrpc 2011-07-21 08:40:26 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1079.html

Comment 20 errata-xmlrpc 2011-07-21 12:33:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1079.html


Note You need to log in before you can comment on or make changes to this bug.