Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 593723 - openssl-devel: wrong libdir in pkgconfig files
openssl-devel: wrong libdir in pkgconfig files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
: 605585 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 11:16 EDT by Ralf Corsepius
Modified: 2010-06-18 06:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: openssl-1.0.0a-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-15 11:59:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2010-05-19 11:16:19 EDT
Description of problem:

The openssl's pkgconfig files are broken:

# pkg-config --libs libssl
-L/usr/lib6464 -lssl -lcrypto -ldl -lz  

Note: -L/usr/lib6464.


Version-Release number of selected component (if applicable):
openssl-devel-1.0.0-1.fc13.x86_64

Expected results:
# pkg-config --libs libssl
-lssl -lcrypto -ldl -lz


Additional info:
The origin of this bug is this line:
libdir=${exec_prefix}/lib6464

which can be found in each of
/usr/lib64/pkgconfig/libcrypto.pc
/usr/lib64/pkgconfig/libssl.pc
/usr/lib64/pkgconfig/openssl.pc

They all should be
libdir=${exec_prefix}/lib64
Comment 1 Tomas Mraz 2010-05-19 11:27:16 EDT
As this is harmless so rather a cosmetic bug I'll fix it in rawhide only and push it to F13 and older releases only in case something more serious comes up.
Comment 2 Fedora Update System 2010-06-07 03:53:20 EDT
openssl-1.0.0a-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openssl-1.0.0a-1.fc13
Comment 3 Fedora Update System 2010-06-07 03:53:50 EDT
openssl-1.0.0a-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openssl-1.0.0a-1.fc12
Comment 4 Fedora Update System 2010-06-07 18:16:21 EDT
openssl-1.0.0a-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openssl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openssl-1.0.0a-1.fc13
Comment 5 Fedora Update System 2010-06-07 18:28:32 EDT
openssl-1.0.0a-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openssl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openssl-1.0.0a-1.fc12
Comment 6 Fedora Update System 2010-06-15 11:58:58 EDT
openssl-1.0.0a-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-06-16 13:44:04 EDT
openssl-1.0.0a-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Tomas Mraz 2010-06-18 06:58:21 EDT
*** Bug 605585 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.