Bug 59373 - installer stops and ask to save or debug the bug
installer stops and ask to save or debug the bug
Status: CLOSED DUPLICATE of bug 19523
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-06 11:56 EST by Pravin
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 11:56:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pravin 2002-02-06 11:56:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1466, in 
doInstall
    self.fstab.makeFilesystems ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 664, in 
makeFilesystems
    isys.umount("/mnt/loophost")
  File "/usr/lib/anaconda/isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

Local variables in innermost frame:
what: /mnt/loophost
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.While installing the linux 7.0
2.After copying files it gives error message something about anaconda.
3.It asks for  OK  SAVE or DEBUG

debug & ok doesnt work.
so i saved the file on floppy .......


Actual Results:  the saved file is as followsTraceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1466, in 
doInstall
    self.fstab.makeFilesystems ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 664, in 
makeFilesystems
    isys.umount("/mnt/loophost")
  File "/usr/lib/anaconda/isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

Local variables in innermost frame:
what: /mnt/loophost
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

After saving this it asks for reboot
So i have to restart m/c & try install it again
same problem occurs everytime 




Expected Results:  It should installed properly insted of having any bug

Additional info:

The bug file contains following information.........

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1466, in 
doInstall
    self.fstab.makeFilesystems ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 664, in 
makeFilesystems
    isys.umount("/mnt/loophost")
  File "/usr/lib/anaconda/isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

Local variables in innermost frame:
what: /mnt/loophost
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Brent Fox 2002-02-06 22:06:37 EST

*** This bug has been marked as a duplicate of 19523 ***

Note You need to log in before you can comment on or make changes to this bug.