Bug 593813 - anaconda traceback 13.21.41 with nightly build on IBM x60 32bit Client install
anaconda traceback 13.21.41 with nightly build on IBM x60 32bit Client install
Status: CLOSED DUPLICATE of bug 592485
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: report (Show other bugs)
6.0
All Linux
urgent Severity medium
: beta
: ---
Assigned To: Gavin Romig-Koch
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-19 14:39 EDT by James G. Brown III
Modified: 2014-12-01 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 09:41:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James G. Brown III 2010-05-19 14:39:20 EDT
Description of problem:

Unable to install nightly build from 5/17 - 5/19. Beta works...


Running anaconda 13.21.41, the Red Hat Enterprise Linux system install er - please wait. 
Traceback (most recent call last):
 File "/usr/bin/anaconda", line 635, in <module>
  import signal, string, isys, iutil, time
 File "/usr/lib/anaconda/isys.py", line 33, in <module>
  import iutil
 File "/usr/lib/anaconda/iutil.py", line 30, in <module>
  from flags import flags
 File "/usr/lib/anaconda/flags.py", line 121, in <module>
  flags = Flags()
 File "/usr/lib/anaconda/flags.py", line 91, in __init__
  self.__dict__['flags']['cmdline'] = self.createCmdlineDict()
 File "/usr/lib/anaconda/flags.py", line 55, in createCmdlineDict
  lst = shlex.split(cmdline)
 File "/usr/lib/python2.6/shlex.py", line 279, in split
  return list(lex)
 File "/usr/lib/python2.6/shlex.py", line 269, in next
  token = self.get_token()
 File "/usr/lib/python2.6/shlex.py", line 279, in get_token
  raw = self.read_token()
 File "/usr/lib/python2.6/shlex.py", line 279, in read_token
  raise ValueError, "No closing quotation"
ValueError: No closing quotation
install exited abnormally [1/1]


anaconda.log and syslog following
Comment 4 David Lehman 2010-05-19 16:08:09 EDT
The error you received:

> ValueError: No closing quotation

The kernel command line you provided:

> Kernel command line: initrd=initrd.img repo=hd:UUID=C983-0AA3:/  Hat Enterprise
Linux" askmethod BOOT_IMAGE=vmlinuz

Notice that there is exactly one quotation mark in that command line? That's
the problem. Is that kernel command line provided by you or by some pre-built/provided media?
Comment 5 James G. Brown III 2010-05-19 16:11:54 EDT
By the prebuilt boot.iso media...

- James
Comment 6 Dennis Gregorovic 2010-05-19 17:14:29 EDT
Any guidance as to where this problem is being introduced?  I'm not aware of any recent changes on my end that would cause this, and boot.iso is produced by anaconda during buildinstall.
Comment 7 David Lehman 2010-05-19 18:14:21 EDT
Where are you getting this boot.iso from? I'm looking in the nightly trees from 20100517-20100519 and there is not one isolinux.cfg that includes a repo= parameter.

It seems like you are hand-editing the boot command line in spite of the fact that you told me you got it from boot.iso.
Comment 8 James G. Brown III 2010-05-19 18:21:14 EDT
Dave, I didn't make any manual changes. I booted with a DVD from yesterday's build and then the boot iso from the 17th and the 19th. I hit enter at the menu prompt where one might make a manual change, but again I did not... I'll run through this again tomorrow and verify. 

- James
Comment 9 James G. Brown III 2010-05-20 07:52:19 EDT
Dave, I think I know what happened. I used livecd-iso-to-disk with the boot.iso from the 17th and 19th, which is likely what malformed the kernel cmdline... (should have just used dd...)

I received a *different* backtrace at the same place when trying to install using the DVD (burned with brasero) that has a .buildstamp 201005181540.i386.

I didn't realize at first these weren't one in the same sorry for the confusion.

The backtrace I am receiving from the DVD (which I also verified the media) is 

Running anaconda 13.21.41, the Red Hat Enterprise Linux system installer -
please wait. 
06:28:06 Starting graphical installation.
Traceback (most recent call last):
 File "/usr/bin/anaconda", line 1021, in <module>
  from exception import initExceptionHandling
 File "/usr/lib/anaconda/exception.py", line 24, in <module>
  from meh.handler import *   
 File "/usr/lib/python2.6/site-packages/meh/handler.py", line 25, in <module>
  import report.accountmanager
 File "/usr/lib/python2.6/site-packages/report/__init__.py", line 36, in <module>
  from report import io as iomodule
 File "/usr/lib/python2.6/site-packages/report/io/__init__.py", line 13, in <module>
  priority = prio_mappings[config.get("main","loglevel")]
 File "/usr/lib/python2.6/ConfigParser.py", line 311, in get
  raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'main'
install exited abnormally [1/1]

I'll verify the nightly from today for any change...
Comment 10 Dennis Gregorovic 2010-05-20 08:11:21 EDT
Moving back to anaconda.  Looks like etc/report.conf is missing from the install image.
Comment 11 David Cantrell 2010-05-20 09:41:02 EDT

*** This bug has been marked as a duplicate of bug 592485 ***

Note You need to log in before you can comment on or make changes to this bug.