Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 594034 - missing shared libraries in rescue mode for shutdown [NEEDINFO]
missing shared libraries in rescue mode for shutdown
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Martin Gracik
Release Test Team
:
Depends On:
Blocks: 582286 601607
  Show dependency treegraph
 
Reported: 2010-05-20 07:56 EDT by Pavel Holica
Modified: 2013-07-04 08:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.48-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 601607 (view as bug list)
Environment:
Last Closed: 2010-07-02 16:49:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
atodorov: needinfo? (mgracik)


Attachments (Terms of Use)

  None (edit)
Description Pavel Holica 2010-05-20 07:56:37 EDT
Description of problem:
Running shutdown in rescue mode ends with error complaining about missing shared libraries.

Version-Release number of selected component (if applicable):
RHEL6.0-20100512.0 x86_64 Server
anaconda-13.21.39-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. start rescue mode
2. start shell
3. run shutdown
  
Actual results:
bash-4.1# shutdown
shutdown: error while loading shared libraries: libnih.so.1: cannot open shared object file: no such file or directory

Expected results:
shutdown should work or shouldn't be present

Additional info:
Comment 1 RHEL Product and Program Management 2010-05-20 08:06:33 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Pavel Holica 2010-05-26 04:17:12 EDT
Ok, I've found now, that this happens only if previously installed system is mounted into /mnt/sysimage (without manual chroot-ing).
Comment 3 Pavel Holica 2010-05-26 04:22:44 EDT
The problem is in PATH variable, it contains /mnt/sysimage/bin, /mnt/sysimage/sbin, /mnt/sysimage/usr/bin/ ...
Comment 4 Martin Gracik 2010-05-26 11:18:10 EDT
The problem was with library paths on 64 bit architectures, fixed in version anaconda-13.21.48-1
Comment 6 Alexander Todorov 2010-05-31 08:11:16 EDT
With anaconda-13.21.48 there's no error message about the missing shared library. However the system will not shutdown:

In the rescue shell type: shutdown -h now  - nothing happens.

Martin,
is this related or a separate bug?
Comment 7 Alexander Todorov 2010-06-08 06:14:11 EDT
(In reply to comment #6)
> With anaconda-13.21.48 there's no error message about the missing shared
> library. However the system will not shutdown:
> 
> In the rescue shell type: shutdown -h now  - nothing happens.
> 

Discussed with Martin on IRC and filed as bug #601607. Moving this one to VERIFIED.
Comment 8 releng-rhel@redhat.com 2010-07-02 16:49:57 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.