Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 601607 - shutdown doesn't work in rescue mode
shutdown doesn't work in rescue mode
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Martin Sivák
Release Test Team
: Reopened
Depends On: 594034
Blocks: 582286
  Show dependency treegraph
 
Reported: 2010-06-08 06:12 EDT by Alexander Todorov
Modified: 2010-06-18 06:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 594034
Environment:
Last Closed: 2010-06-18 06:13:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2010-06-08 06:12:32 EDT
+++ This bug was initially created as a clone of Bug #594034 +++

--- Additional comment from atodorov@redhat.com on 2010-05-31 15:11:16 EEST ---

With anaconda-13.21.48 there's no error message about the missing shared library. However the system will not shutdown:

In the rescue shell type: shutdown -h now  - nothing happens.
Comment 1 Martin Sivák 2010-06-17 08:57:42 EDT
The shutdown binary is not part of the install/rescue environment, but it was found on the rescued system (/mnt/sysimage/sbin/shutdown). It can't work since you are not running regular init, but only stripped rescue one.

Use poweroff, reboot or halt to stop the rescue system.
Comment 2 Alexander Todorov 2010-06-18 05:27:53 EDT
Martin,
poweroff and halt will not work as well if executed while inside the chroot.
Comment 3 Martin Sivák 2010-06-18 06:13:14 EDT
No they won't. And never will. At least until we change the init system.

Again.. we do not have any runlevels in rescue, no init socket and we do not accept commands from telinit, so you have to use rescue tools which use proper signaling for rescue mode.

Use poweroff or halt from the rescue environment. It has preference in PATH so you are using rescue stuff over the installed stuff (which is not guaranteed to work at all. And broken system is the reason to run rescue, isn't it).

Note You need to log in before you can comment on or make changes to this bug.