Bug 5944 - Exception error in installing RedHat 6.1
Exception error in installing RedHat 6.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-14 06:35 EDT by khafagy
Modified: 2008-05-01 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-30 13:46:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description khafagy 1999-10-14 06:35:16 EDT
Hello,

I am installing redhat6.1 from harddrive and I am using the
boot.img (local boot diskette) for booting, I have the
following error:

- In the Reading package information phase during the
installation (after specifying upgrade installation class)
I got the following "exception error" which can not be
ignored:

Trace back (innermost last):

file "/usr/bin/anaconda.real", line 225 in ?
intforun (todo, test=test)

file "/tmp/lib/python1.5/site-packages/text.py", line 1000,
in run rc = apply (step[1](), step[2])

file "/tmp/lib/python1.5/site-packages/text.py", line 251,
in --call-- todo.upgradefindpackage (root)

file "/tmp/lib/python1.5/site-packages/todo.py", line 942,
in getcompslist self.getheaderlist()

file "/tmp/lib/python1.5/site-packages/todo.py, line 930,
in getheaderlist self.method.readheader ()

file "/tmp/lib/python1.5/site-packages/isys.py", line 9
in umount return _isys.umount return _isys.umount (what)
system error : (16, device or resource busy)


Note: the graphical installation does not work only text
mode.

Please send me an answer if there is error in the
installation files or the installation process.

Waiting for your fedback..

Regards,
Email: khafagy@hotmail.com

------- Additional Comments From   10/26/99 20:18 -------
I have the same exact bug.  It works perfectly until it says "reading
packages" then boom, Exception Occurs.

Traceback (innermost last)

File "/usr/bin/anaconda.real", line 225, in ?

File "/tmp/lib/python1.5/site-packages.todo.py"

(several more lines like the one above appear)

TypeError: unsubscriptable object

I tried the updated install but still no go.
I am also trying to install from my HD.
And for some reason nomatter what I type at the boot: prompt
it always loads the graphical interface.
Comment 1 Jay Turner 1999-11-30 13:46:59 EST
There is reason to believe this error is the result of having corrupt or
incomplete RPM files in the source directory.  Please see bug #6438 for details.

*** This bug has been marked as a duplicate of 6438 ***

Note You need to log in before you can comment on or make changes to this bug.