Bug 6438 - Anaconda in text mode crash after package selection
Anaconda in text mode crash after package selection
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
: 6481 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-27 23:58 EDT by egalanos.
Modified: 2015-01-07 18:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-30 13:48:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description egalanos. 1999-10-27 23:58:24 EDT
After going back and forth with package selection, as the
installer tried to start the package installation I got the
following python error (this is with the updated bootdisk):

File "/usr/bin/anaconda.real", line 225, in ?
	intf.run (todo, test = test)
  File "/tmp/updates/text.py", line 1009, is run
	rc = apply (step[1](), step[2]())
    File "/tmy/updates/text.py", line 572, in __call__
	if todo.doInstall():
    File "/tmp/updates/todo.py", line 1465, in doInstall
	self.method.targetFstab

happened about 4 times.
Comment 1 Jay Turner 1999-10-29 14:08:59 EDT
Could you please send the reminder of the python message that you are
getting.  This is just the top half of it, the window should scroll
down and you will see more of the message.  The really important part
is actually at the end as this is a traceback.
Comment 2 egalanos. 1999-10-30 06:20:59 EDT
I have finally installed RH6.1, and moved around my drives and am
 unable to reproduce this bug.
Comment 3 richard.meer 1999-11-01 17:08:59 EST
Hi,
Im getting the same exeption
here it goes:
exeption occured

traceback( innermost last ):

file "/usr/bin/anaconda.real", line 225, in ? intf.run(todo,
test=test)
file "/tmp/lib/python1.5/site-packages/text.py", line 1000, in runrc=
apply (step[1](), step[2])
file "/tmp/lib/python1.5/site-packages/text.py", line 468, in
__call__ todo.GetCompsList()
file "/tmp/lib/python1.5/site-packages/todo.py", line 942, in
GetCompsList self.getheaderList()
file "/tmp/lib/python1.5/site-packages/harddrive.py", line 45, in
readheaders isys.unmount("/tmp/hdimage")
file "/tmp/lib/python1.5/site-packages/isys.py", line 8, in unmount
return_isys.unmount(what)

systemerror: (16, 'Device or recource busy')

Richard.

------- Additional Comments From   11/02/99 00:05 -------
jturner@redhat, this is getting to be really old. This seems to be the
same old bug we've had for a while now with a few different "line
numbers" in the File. See bugs #6278, #6481, #5555, and #5944!!!!
Comment 4 richard.meer 1999-11-02 15:15:59 EST
Hi,
I've had this bug in the instalation of LINUX and some people advised
me to check the RPMS directory for anny files not ending with .RPM
I dis that and foun an log file from my FTP prog. deleted the file
and tryed the install agean, it still did'nt work ( for some other
people this did work !!) Then I compared the files in that dir with
the files on the FTP site and found out that a file called HOWTO-
corean..... something was'nt completly downloaded. I redownloaded
this file and the install worked well !! so check your RPMS dir, it
should be 555.198.893 bytes large, if it is'nt check your RPM files !!
Comment 5 Jay Turner 1999-11-30 13:43:59 EST
*** Bug 6278 has been marked as a duplicate of this bug. ***
Comment 6 Jay Turner 1999-11-30 13:45:59 EST
*** Bug 6481 has been marked as a duplicate of this bug. ***
Comment 7 Jay Turner 1999-11-30 13:46:59 EST
*** Bug 5944 has been marked as a duplicate of this bug. ***
Comment 8 Jay Turner 1999-11-30 13:48:59 EST
I think this problem is solved with verification that the RPM files in the
source directory are not corrupt or incomplete.  Please reopen if the problem
persists with known good RPM files.  We will put better error handling into the
next release.
Comment 9 Burton Radons 1999-12-06 07:30:59 EST
I do not know if this is a faux pas here, but I ran into this bug and sketched a
crummy little/big confirmer for DJGPP/DOS, posted at
"http://www.pacificcoast.net/~loth/check.exe" with the source at check.c same
path.  Run in RedHat/RPMS with a good ls-lr in the directory and it will list
the mismatches in size.

Note You need to log in before you can comment on or make changes to this bug.