Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 594594 - start domain failed with qemu-kvm-0.12.1.2-2.60.el6
start domain failed with qemu-kvm-0.12.1.2-2.60.el6
Status: CLOSED DUPLICATE of bug 593909
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 02:19 EDT by dyuan
Modified: 2010-05-21 04:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-21 04:54:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dyuan 2010-05-21 02:19:31 EDT
Description of problem:
start domain failed with qemu-kvm-0.12.1.2-2.60.el6.
it does work fine with qemu-kvm-0.12.1.2-2.54.el6.

Version-Release number of selected component (if applicable):
libvirt-0.8.1-6.el6.x86_64
kernel-2.6.32-28.el6.x86_64
selinux-policy-3.7.19-19.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. upgrade qemu-kvm
2. # service libvirtd restart
3. start domain
# virsh start demo58
error: Failed to start domain demo58
error: internal error Process exited while reading console log output: char device redirected to /dev/pts/3
qemu: could not open disk image /mnt/vol/rhel5u5_x86_64.img: Invalid argument
  
Actual results:
start domain failed

Expected results:
start successfully

Additional info:

# tail -f /var/log/messages
May 21 14:21:04 dhcp-66-70-43 kernel: device vnet0 entered promiscuous mode
May 21 14:21:04 dhcp-66-70-43 kernel: virbr0: topology change detected, propagating
May 21 14:21:04 dhcp-66-70-43 kernel: virbr0: port 1(vnet0) entering forwarding state
May 21 14:21:04 dhcp-66-70-43 kernel: virbr0: port 1(vnet0) entering disabled state
May 21 14:21:04 dhcp-66-70-43 kernel: device vnet0 left promiscuous mode
May 21 14:21:04 dhcp-66-70-43 kernel: virbr0: port 1(vnet0) entering disabled state
May 21 14:21:04 dhcp-66-70-43 libvirtd: 14:21:04.402: error : qemudReadLogOutput:2251 : internal error Process exited while reading console log output: char device redirected to /dev/pts/1#012qemu: could not open disk image /mnt/vol/rhel5u5_x86_64.img: Invalid argument#012
May 21 14:21:04 dhcp-66-70-43 libvirtd: 14:21:04.470: error : SELinuxRestoreSecurityFileLabel:377 : internal error cannot restore selinux file label for /mnt/vol/rhel5u5_x86_64.img
Comment 2 dyuan 2010-05-21 03:23:57 EDT
# rpm -qa|grep qemu
qemu-kvm-0.12.1.2-2.60.el6.x86_64
qemu-img-0.12.1.2-2.60.el6.x86_64

# /usr/libexec/qemu-kvm -smp 1 -m 512M  -drive file=/mnt/vol/rhel5u5_i386.img,media=disk,if=ide,boot=on -name demo -usbdevice tablet -vnc :10 -monitor stdio
qemu: could not open disk image /mnt/vol/rhel5u5_i386.img: Invalid argument


# rpm -Uvh qemu-kvm-0.12.1.2-2.54.el6.x86_64.rpm qemu-img-0.12.1.2-2.54.el6.x86_64.rpm  --force
Preparing...                ########################################### [100%]
   1:qemu-img               ########################################### [ 50%]
   2:qemu-kvm               ########################################### [100%]

# rpm -qa|grep qemu
qemu-kvm-0.12.1.2-2.54.el6.x86_64
qemu-img-0.12.1.2-2.54.el6.x86_64

# /usr/libexec/qemu-kvm -smp 1 -m 512M  -drive file=/mnt/vol/rhel5u5_i386.img,media=disk,if=ide,boot=on -name demo -usbdevice tablet -vnc :10 -monitor stdio
QEMU 0.12.1 monitor - type 'help' for more information
(qemu)
Comment 3 dyuan 2010-05-21 04:54:46 EDT

*** This bug has been marked as a duplicate of bug 593909 ***

Note You need to log in before you can comment on or make changes to this bug.