Bug 593909 - VM can not start by using qemu-kvm-0.12.1.2-2.56.el6
Summary: VM can not start by using qemu-kvm-0.12.1.2-2.56.el6
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm   
(Show other bugs)
Version: 6.0
Hardware: All Linux
high
high
Target Milestone: beta
: ---
Assignee: Juan Quintela
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: Regression, TestBlocker
: 594594 595313 595439 595518 595790 598727 (view as bug list)
Depends On:
Blocks: 494837
TreeView+ depends on / blocked
 
Reported: 2010-05-20 02:57 UTC by Mike Cao
Modified: 2013-01-09 22:36 UTC (History)
16 users (show)

Fixed In Version: qemu-kvm-0.12.1.2-2.61.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 05:52:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Cao 2010-05-20 02:57:37 UTC
Description of problem:
VM can not start with virtual blocks.

Version-Release number of selected component (if applicable):
# uname -r
2.6.32-25.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.56.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.start a vm by using following command:
usr/libexec/qemu-kvm -rtc-td-hack -bt hci,vlan=0 -no-hpet -usbdevice tablet -drive file=/RHEL-Server-6.0-64.raw,if=ide,format=raw -net nic,macaddr=20:10:43:23:33:42,model=e1000,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -uuid `uuidgen` -vnc :5 -boot dc -cpu qemu64,+sse2 -smp 2 -m 2G -monitor stdio -balloon none -startdate now
"qemu: could not open disk image /RHEL-Server-6.0-64.raw: Success"

2.start a vm by using following command:
# #/usr/libexec/qemu-kvm -rtc-td-hack -no-hpet -usbdevice tablet -drive file=RHEL-Server-5.5-64-virtio.qcow2,media=disk,if=none,id=test -device ide-drive,drive=test -uuid `uuidgen` -vnc :5 -cpu qemu64,+sse2 -smp 2 -m 2G -monitor stdio -balloon none -boot c
qemu: could not open disk image RHEL-Server-5.5-64-virtio.qcow2: Invalid argument

  
Actual results:


Expected results:
the VM can start successfully.

Additional info:
DownGrade the qemu-kvm to qemu-kvm-0.12.1.2-2.55.el6.x86_64
Start the VM with same command .the VM can start successfully.
It is a regression bug.

Comment 3 Mike Cao 2010-05-21 01:40:42 UTC
Retest from qemu-kvm-0.12.1.2-2.57.el6.x86_64 to qemu-kvm-0.12.1.2-2.60.el6.x86_64,with the same images by using the same commandline.

Still hit this issue.

Comment 4 dyuan 2010-05-21 08:54:47 UTC
*** Bug 594594 has been marked as a duplicate of this bug. ***

Comment 5 Dor Laor 2010-05-24 07:40:07 UTC
I suspect you have the wrong parameters. Try without format=raw.
Also we only support cache=none.

Comment 6 Mike Cao 2010-05-24 10:35:00 UTC
(In reply to comment #5)
> I suspect you have the wrong parameters. Try without format=raw.
> Also we only support cache=none.    

start VM in qemu-kvm-0.12.1.2-2.56.el6.x86_64.
CLI:/usr/libexec/qemu-kvm -rtc-td-hack -no-hpet -usbdevice tablet -drive file=/home/RHEL-Server-5.5-64-virtio.raw,if=virtio,cache=none,boot=on -net nic,macaddr=20:10:43:23:33:42,model=e1000,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -uuid `uuidgen` -vnc :5 -boot dc -cpu qemu64,+sse2 -smp 2 -m 2G -monitor stdio -balloon none -startdate now

Expected Results:
the vm can not start. Error msg:
qemu: could not open disk image /home/RHEL-Server-5.5-64-virtio.raw: Success

Start VM with same command in qemu-kvm-0.12.1.2-2.55.el6.x86_64.the VM can start successfully.

Comment 7 Dor Laor 2010-05-24 11:01:40 UTC
Kevin, any hints?

Comment 8 Juan Quintela 2010-05-24 11:13:07 UTC
Patch sent to the list.

"raw" image format/protocol was split into "raw" protocol and "file" image.  But we didn't changed the block whitelist.

I will use this bugzilla instead of a change to the bugzilla that introduced the regression.

Comment 9 Daniel Berrange 2010-05-24 11:20:29 UTC
*** Bug 595313 has been marked as a duplicate of this bug. ***

Comment 10 Daniel Berrange 2010-05-24 16:01:16 UTC
*** Bug 595439 has been marked as a duplicate of this bug. ***

Comment 13 Juan Quintela 2010-05-24 22:04:32 UTC
*** Bug 595518 has been marked as a duplicate of this bug. ***

Comment 14 Mike Cao 2010-05-25 01:42:41 UTC
Verified this bug in qemu-kvm-0.12.1.2-2.62.el6.x86_64.

Repeat steps in the description,the VM can start,and work on well.

the bug has already been fixed.

Comment 19 Daniel Berrange 2010-05-28 08:25:55 UTC
*** Bug 595790 has been marked as a duplicate of this bug. ***

Comment 20 Mike Cao 2010-06-02 05:52:13 UTC
According to Comment #14 ,close this bug.

Comment 21 Cole Robinson 2010-06-09 19:33:16 UTC
*** Bug 598727 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.