Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 594881 - writes NM_CONTROLLED=no to wlan config file
writes NM_CONTROLLED=no to wlan config file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Radek Vykydal
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-21 16:24 EDT by Bill Nottingham
Modified: 2014-03-16 23:23 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-13.21.52-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:44:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2010-05-21 16:24:48 EDT
Description of problem:

I did a network install using boot.iso. I did not ask to set up wlan0, because it wasn't my install interface. anaconda wrote NM_CONTROLLED=no to it, effectively breaking it out-of-the-box

Version-Release number of selected component (if applicable):

RHEL6.0-20100521.n.0
Comment 2 Radek Vykydal 2010-05-26 08:27:09 EDT
Currently (after my nm-c-e integration set of patches) we set a network device
as NM_CONTROLLED only if it is selected when enabling network (be it in stage
1 or stage 2) or in pre nm-c-e dialog when configuring network in stage 2.

I was thinking about writing out "yes" by default specifically for wireless devices. I wanted to do it already in stage 1, so that setting the wlan as not controlled by NM in stage 2 UI by user is preserved. I've already added some bits we'd need to do this (wireless device detection) to master while working on support for wireless (bug 473803), but wireless support is not going to rhel 6.0.

Alternatively, for 6.0, independently of wireless support patches, I can set wireless devices as NM_CONTROLLED at the beginning of stage 2 with a simple patch below. Maybe it is even better than setting in stage 1 when I am thinking about it now.


diff --git a/network.py b/network.py
index 8b0d109..7c664bf 100644
--- a/network.py
+++ b/network.py
@@ -316,6 +316,8 @@ class Network:
         self.overrideDHCPhostname = False
 
         self.update()
+        # We want wireless devices to be nm controlled by default
+        self.controlWireless()
 
     def update(self):
 
@@ -441,6 +443,11 @@ class Network:
                 ifaces.append(iface)
         return ifaces
 
+    def controlWireless(self):
+        for devname, device in self.netdevices.items():
+            if isys.isWireless(devname):
+                device.set(('NM_CONTROLLED', 'yes'))
+
Comment 3 Bill Nottingham 2010-05-26 15:57:03 EDT
I think that the simpler solution is to just not write NM_CONTROLLED, period. (either yes or no)
Comment 4 RHEL Product and Program Management 2010-06-02 10:45:42 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Radek Vykydal 2010-06-17 04:51:50 EDT
This should be fixed in anaconda-13.21.52-1.
Comment 6 Chris Lumens 2010-06-22 15:28:12 EDT
*** Bug 606745 has been marked as a duplicate of this bug. ***
Comment 8 Lubos Kocman 2010-07-01 10:16:22 EDT
Verified on anaconda-13.21.54-1.el6  

I was facing this issue as well and I haven't met this issue on clean install of RHEL 6.0-{20100628, 20100629}.
Comment 9 releng-rhel@redhat.com 2010-11-10 14:44:42 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.