Bug 59495 - Bad CFLAGS in a lot of *-config scripts
Bad CFLAGS in a lot of *-config scripts
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Brock Organ
: MoveUpstream, Triaged
Depends On: 59496 59497 59498 59499 59500 59501 59502 59503 59504 59505 59506 59507 59508
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-08 19:11 EST by Enrico Scholz
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 22:31:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-02-08 19:11:47 EST
gcc-3.1 issues warnings when specifying standard includes on the
cmd-line; e.g:

| $ gcc -I /usr/include -E -
| cpp0: warning: changing search order for system directory "/usr/include"
| cpp0: warning:   as it has already been specified as a non-system directory

Unfortunately, a *lot* of Hampton Beta 1 packages are setting such
directives in their *-config scripts:

| $ pkg-config oaf --cflags
|  -I/usr/include -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/include/orbit-1.0  
   ~~~~~~~~~~~~~~

As you can imagine, this will break -Werror builds (e.g. used while
developing own projects). Since there are good reasons to warn about
such bad '-I...', the affected packages must be fixed.

I will use this report as a reference-point for bugs regarding this
issue.
Comment 1 Havoc Pennington 2002-02-11 11:27:18 EST
Why is this on gcc? Maybe we need a "general" component
Comment 2 Jay Turner 2002-02-19 12:42:40 EST
OK, what's the status of this?
Comment 3 Enrico Scholz 2002-02-19 13:03:20 EST
The packages affected by this bug and found by me are listed as an dependency.
Three of them are fixed.
Comment 4 Havoc Pennington 2002-02-21 00:20:07 EST
I'm planning to fix my packages but don't have an ETA.
Comment 5 Havoc Pennington 2003-01-12 22:31:43 EST
Closing this tracking bug, as it's on a weird component and I'm not really using 
it to track (not dealing with these bugs as a group).

Note You need to log in before you can comment on or make changes to this bug.