Bug 594983 - SELinux is preventing /usr/libexec/gdm-session-worker "create" access on .xsession-errors.
SELinux is preventing /usr/libexec/gdm-session-worker "create" access on...
Status: CLOSED DUPLICATE of bug 594993
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:d44ec2e620c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-22 10:37 EDT by chocomilk
Modified: 2010-05-24 07:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 07:24:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chocomilk 2010-05-22 10:37:44 EDT
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "create" access on
.xsession-errors.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_t:s0
Target Objects                .xsession-errors [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.28.2-3.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-114.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux a1m 2.6.32.12-115.fc12.i686 #1 SMP Fri Apr
                              30 20:34:53 UTC 2010 i686 i686
Alert Count                   8
First Seen                    Thu 20 May 2010 09:29:30 AM CDT
Last Seen                     Sat 22 May 2010 09:23:45 AM CDT
Local ID                      1c754f36-4831-4a71-9f03-cbde0e5ae0b9
Line Numbers                  

Raw Audit Messages            

node=a1m type=AVC msg=audit(1274538225.192:23): avc:  denied  { create } for  pid=1706 comm="gdm-session-wor" name=".xsession-errors" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_t:s0 tclass=file

node=a1m type=AVC msg=audit(1274538225.192:23): avc:  denied  { append } for  pid=1706 comm="gdm-session-wor" name=".xsession-errors" dev=sda6 ino=843786 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_t:s0 tclass=file

node=a1m type=SYSCALL msg=audit(1274538225.192:23): arch=40000003 syscall=5 success=yes exit=9 a0=8f8e860 a1=442 a2=180 a3=8f8e860 items=0 ppid=1690 pid=1706 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-session-wor,xdm_t,var_t,file,create
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t var_t:file { create append };
Comment 1 Miroslav Grepl 2010-05-24 07:24:31 EDT

*** This bug has been marked as a duplicate of bug 594993 ***

Note You need to log in before you can comment on or make changes to this bug.