Bug 594993 - SELinux is preventing /usr/libexec/gdm-session-worker "write" access on /var/local/home/mmendez/.xsession-errors.
Summary: SELinux is preventing /usr/libexec/gdm-session-worker "write" access on ...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
(Show other bugs)
Version: 12
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:002153c1e32...
Keywords:
: 594983 594995 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-22 16:34 UTC by chocomilk
Modified: 2010-06-15 11:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 11:40:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description chocomilk 2010-05-22 16:34:52 UTC
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "write" access on
/var/local/home/mmendez/.xsession-errors.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_t:s0
Target Objects                /var/local/home/mmendez/.xsession-errors [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.28.2-3.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-114.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32.12-115.fc12.i686 #1 SMP Fri Apr
                              30 20:34:53 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Sat 22 May 2010 11:31:07 AM CDT
Last Seen                     Sat 22 May 2010 11:31:07 AM CDT
Local ID                      fd435e0b-89c0-479b-a17a-2e382fea20e5
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274545867.367:24): avc:  denied  { write } for  pid=1785 comm="gdm-session-wor" name=".xsession-errors" dev=sda6 ino=843817 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1274545867.367:24): arch=40000003 syscall=93 success=yes exit=0 a0=9 a1=0 a2=9 a3=932b898 items=0 ppid=1769 pid=1785 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-session-wor,xdm_t,var_t,file,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t var_t:file write;

Comment 1 Miroslav Grepl 2010-05-24 11:24:31 UTC
*** Bug 594983 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2010-05-24 11:25:13 UTC
*** Bug 594995 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2010-05-24 11:40:53 UTC
You need to label /var/local/home/mmendez as being a users homedir.

# semanage fcontext -a -e /home/mmendez /var/local/home/mmendez
# restorecon -Rv /var/local/home

Should fix the labeling.


Note You need to log in before you can comment on or make changes to this bug.