Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 595313 - libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/0
libvirtError: internal error Process exited while reading console log output:...
Status: CLOSED DUPLICATE of bug 593909
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.0
All Linux
high Severity high
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
: TestBlocker
Depends On:
Blocks: 582286
  Show dependency treegraph
 
Reported: 2010-05-24 06:59 EDT by Alexander Todorov
Modified: 2010-05-24 07:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-24 07:20:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2010-05-24 06:59:10 EDT
Description of problem:
On fresh RHEL6 (snap #5) installation I get a traceback when trying to create a new guest:

qemu: could not open disk image /var/lib/libvirt/images/srvd1.img: Invalid argument
' : Unable to complete install '<class 'libvirt.libvirtError'> internal error Process exited while reading console log output: char device redirected to /dev/pts/0
qemu: could not open disk image /var/lib/libvirt/images/srvd1.img: Invalid argument

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1559, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 972, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1037, in _do_install
    "install")
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1008, in _create_guest
    dom = self.conn.createLinux(start_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1262, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/0
qemu: could not open disk image /var/lib/libvirt/images/srvd1.img: Invalid argument

'

I have SELinux in permissive mode.

Version-Release number of selected component (if applicable):
libvirt-0.8.1-6.el6.x86_64
virt-manager-0.8.4-3.el6.noarch


How reproducible:
always


Steps to Reproduce:
1. Create new guest with virt-manager using default settings.
2.
3.
  
Actual results:
Traceback

Expected results:
new guest is created

Additional info:
Comment 1 Daniel Berrange 2010-05-24 07:20:29 EDT
This is a KVM bug 593909

*** This bug has been marked as a duplicate of bug 593909 ***

Note You need to log in before you can comment on or make changes to this bug.