Bug 595401 - [abrt] crash in gnome-lirc-properties-0.4.0-1.fc12: connection.py:630:call_blocking:DBusException: org.freedesktop.PolicyKit1.Error.Failed: Error parsing subject struct
Summary: [abrt] crash in gnome-lirc-properties-0.4.0-1.fc12: connection.py:630:call_bl...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-lirc-properties   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:08997608
Keywords:
: 607113 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 14:25 UTC by Tomasz Torcz
Modified: 2010-06-23 17:50 UTC (History)
14 users (show)

Fixed In Version: gnome-lirc-properties-0.5.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 17:50:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.90 KB, text/plain)
2010-05-24 14:25 UTC, Tomasz Torcz
no flags Details

Description Tomasz Torcz 2010-05-24 14:25:10 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/gnome-lirc-properties
component: gnome-lirc-properties
executable: /usr/bin/gnome-lirc-properties
kernel: 2.6.33.4-95.fc13.x86_64
package: gnome-lirc-properties-0.4.0-1.fc12
reason: connection.py:630:call_blocking:DBusException: org.freedesktop.PolicyKit1.Error.Failed: Error parsing subject struct
release: Fedora release 13 (Goddard)

backtrace
-----
connection.py:630:call_blocking:DBusException: org.freedesktop.PolicyKit1.Error.Failed: Error parsing subject struct

Traceback (most recent call last):
  File "/usr/bin/gnome-lirc-properties", line 27, in <module>
    gnome_lirc_properties.run(sys.argv[1:], datadir)
  File "/usr/lib/python2.6/site-packages/gnome_lirc_properties/__init__.py", line 57, in run
    return ui.RemoteControlProperties(gtk.glade.XML(ui_filename)).run()
  File "/usr/lib/python2.6/site-packages/gnome_lirc_properties/ui/RemoteControlProperties.py", line 56, in __init__
    self.__setup_authorization()
  File "/usr/lib/python2.6/site-packages/gnome_lirc_properties/ui/RemoteControlProperties.py", line 223, in __setup_authorization
    granted = self.__auth.is_authorized()
  File "/usr/lib/python2.6/site-packages/gnome_lirc_properties/policykit.py", line 45, in is_authorized
    action_id, {}, dbus.UInt32(0), '', timeout=600)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.PolicyKit1.Error.Failed: Error parsing subject struct

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0x291e9b0>
args: (('unix-process', {'pid': dbus.UInt32(10217L, variant_level=1)}), 'org.gnome.lirc-properties.mechanism.configure', {}, dbus.UInt32(0L), '')
utf8_strings: False
bus_name: dbus.UTF8String(':1.29')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: '/org/freedesktop/PolicyKit1/Authority'
timeout: 600
signature: u'(sa{sv})sa{ss}us'
dbus_interface: 'org.freedesktop.PolicyKit1.Authority'
message: <dbus.lowlevel.MethodCallMessage object at 0x249cea0>
method: 'CheckAuthorization'

How to reproduce
-----
1. Happens when I try to run g-l-p freshly after installing it.

Comment 1 Tomasz Torcz 2010-05-24 14:25:13 UTC
Created attachment 416137 [details]
File: backtrace

Comment 2 Wolfgang Ulbrich 2010-05-25 07:37:30 UTC
Package: gnome-lirc-properties-0.5.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Everytime i start gnome-lirc-properties i get this error and gnome-lirc-properties didn't start.
2.
3.

Comment 3 Mohamed El Morabity 2010-05-26 00:11:19 UTC
Package: gnome-lirc-properties-0.4.0-1.fc12
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Plug an IR device
2. Launch gnome-lirc-properties... 



Comment
-----
The application crashes too when no IR device is plugged.

Comment 4 Peter Robinson 2010-05-30 08:55:46 UTC
Package: gnome-lirc-properties-0.5.0-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. run "Infrared remote control" from the system menu.
2. crash

Running it from the command line also gave me

WARNING:root:/usr/share/lirc-remotes/: Remote Antec_Veris_Premiere listed twice in imon/lircd.conf.imon-mceusb and imon/lircd.conf.imon-antec-veris.

Just before the crash

Comment 5 Dmitry M 2010-05-30 23:15:03 UTC
Package: gnome-lirc-properties-0.4.0-1.fc12
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
install and run gnome-lirc-properties under f13

Comment 6 Eric Moret 2010-06-04 04:21:12 UTC
Package: gnome-lirc-properties-0.4.0-1.fc12
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. start infrared remote control, observe the crash attached
2.
3.

Comment 7 Anthony Name 2010-06-05 10:20:55 UTC
Package: gnome-lirc-properties-0.4.0-1.fc12
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.  Click on Infra Red Remote Control in System --> Preferences
2.
3.


Comment
-----
Gnome-lirc-properties crashes when starting

Comment 8 amdepass 2010-06-05 22:51:32 UTC
Package: gnome-lirc-properties-0.4.0-1.fc12
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Tried to start Infared Remote Control from System > Preferences
2.
3.

Comment 9 "FeRD" (Frank Dana) 2010-06-07 16:34:07 UTC
Package: gnome-lirc-properties-0.4.0-1.fc12
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Attempt to run System > Preferences > Hardware > Infrared Remote Control
2. falldowngoboom
3. ...at least there's no step 3!

Comment
-----
Other LIRC-ness installed:

% sudo yum list installed \*lirc\*
Installed Packages
gnome-lirc-properties.noarch                0.4.0-1.fc12                @fedora 
lirc.x86_64                                 0.8.6-6.fc13                @updates
lirc-devel.x86_64                           0.8.6-6.fc13                @updates
lirc-doc.x86_64                             0.8.6-6.fc13                @updates
lirc-libs.x86_64                            0.8.6-6.fc13                @updates
lirc-remotes.x86_64                         0.8.6-6.fc13                @updates
pulseaudio-module-lirc.x86_64               0.9.21-6.fc13               @fedora 
totem-lirc.x86_64                           2.30.0-2.fc13               @fedora

Comment 10 "FeRD" (Frank Dana) 2010-06-07 16:39:38 UTC
Note also that, other than moving a couple of line numbers in the backtrace, updating to gnome-lirc-properties-0.5.0-1.fc13.noarch @updates-testing changes this crasher not at all.

Comment 11 Fedora Update System 2010-06-07 17:57:20 UTC
gnome-lirc-properties-0.5.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gnome-lirc-properties-0.5.1-1.fc13

Comment 12 Fedora Update System 2010-06-08 19:41:19 UTC
gnome-lirc-properties-0.5.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-lirc-properties'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gnome-lirc-properties-0.5.1-1.fc13

Comment 13 amdepass 2010-06-08 19:47:00 UTC
Package: gnome-lirc-properties-0.4.0-1.fc12
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Tried to start Infared Remote Control from System > Preferences
2.
3.


Comment
-----
updated to the test update via su -c 'yum --enablerepo=updates-testing update gnome-lirc-properties' but still crashes

Comment 14 tiagoma 2010-06-08 21:54:38 UTC
Package: gnome-lirc-properties-0.4.0-1.fc12
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. System -> Preferences -> Infrared remote control
2.
3.


Comment
-----
Open the Gnome menu item just after the package was installed.

Comment 15 Blonďák 2010-06-09 17:57:07 UTC
Package: gnome-lirc-properties-0.4.0-1.fc12
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
run gnome-lirc-properties

Comment 16 Stefan Jensen 2010-06-22 16:33:06 UTC
Package: gnome-lirc-properties-0.4.0-1.fc12
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. try to start "/usr/bin/gnome-lirc-properties"
2. watch backtrace


Comment
-----
I get always a backtrace, when i try to configure my Remote.
right bevor this, i got a Warning: "WARNING:root:/usr/share/lirc-remotes/: Remote Antec_Veris_Premiere listed twice in imon/lircd.conf.imon-antec-veris and imon/lircd.conf.imon-mceusb."

Comment 17 Bastien Nocera 2010-06-23 13:52:49 UTC
*** Bug 607113 has been marked as a duplicate of this bug. ***

Comment 18 Fedora Update System 2010-06-23 17:50:45 UTC
gnome-lirc-properties-0.5.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.