Bug 607113 - gnome-lirc-properties won't start due to policykit behavioural change
gnome-lirc-properties won't start due to policykit behavioural change
Status: CLOSED DUPLICATE of bug 595401
Product: Fedora
Classification: Fedora
Component: gnome-lirc-properties (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-23 05:28 EDT by Chris Lord
Modified: 2010-06-23 09:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 09:52:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lord 2010-06-23 05:28:59 EDT
Description of problem:

If you try to start gnome-lirc-properties, you'll get this:

WARNING:root:/usr/share/lirc-remotes/: Remote Antec_Veris_Premiere listed twice in imon/lircd.conf.imon-antec-veris and imon/lircd.conf.imon-mceusb.
Traceback (most recent call last):
  File "/usr/bin/gnome-lirc-properties", line 27, in <module>
    gnome_lirc_properties.run(sys.argv[1:], datadir)
  File "/usr/lib/python2.6/site-packages/gnome_lirc_properties/__init__.py", line 57, in run
    return ui.RemoteControlProperties(gtk.glade.XML(ui_filename)).run()
  File "/usr/lib/python2.6/site-packages/gnome_lirc_properties/ui/RemoteControlProperties.py", line 56, in __init__
    self.__setup_authorization()
  File "/usr/lib/python2.6/site-packages/gnome_lirc_properties/ui/RemoteControlProperties.py", line 223, in __setup_authorization
    granted = self.__auth.is_authorized()
  File "/usr/lib/python2.6/site-packages/gnome_lirc_properties/policykit.py", line 45, in is_authorized
    action_id, {}, dbus.UInt32(0), '', timeout=600)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.PolicyKit1.Error.Failed: Error parsing subject struct

Version-Release number of selected component (if applicable):

0.4.0-1

How reproducible:

100%

Steps to Reproduce:
1. Run gnome-lirc-properties
  
Actual results:

Python exception

Expected results:

The app loads

Additional info:

This is due to a change in policy-kit that requires the start-time to be specified explicitly in the CheckAuthorization call.

This can be fixed by adding 'start-time':dbus.UInt64(0,variant_level=1) to the subject dict in the CheckAuthorization calls in policykit.py in the gnome-lirc-properties source.
Comment 1 Bastien Nocera 2010-06-23 09:52:49 EDT
Already fixed in updates-testing, and due in the updates shortly.

*** This bug has been marked as a duplicate of bug 595401 ***

Note You need to log in before you can comment on or make changes to this bug.