Bug 595512 - bkr job-cancel NNN: fails with "exceptions.ValueError:need more than 1 value to unpack"
Summary: bkr job-cancel NNN: fails with "exceptions.ValueError:need more than 1 value ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: command line
Version: 0.8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Callaghan
QA Contact:
URL:
Whiteboard:
: 643882 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-24 20:41 UTC by Ed Santiago
Modified: 2019-05-22 13:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-20 00:38:51 UTC


Attachments (Terms of Use)
bkr-submit.xml (1.37 KB, text/xml)
2010-05-24 20:41 UTC, Ed Santiago
no flags Details

Description Ed Santiago 2010-05-24 20:41:25 UTC
Created attachment 416222 [details]
bkr-submit.xml

Description of problem:

$ bkr job-cancel 924
Exception: exceptions.ValueError:need more than 1 value to unpack

Version-Release number of selected component (if applicable):

beaker-client.noarch                   0.5.38-1.el5                    installed

How reproducible:

Two out of two attempts, on two unrelated hosts.

Steps to Reproduce:
1. bkr job-submit see-attachment.xml
2. wait for job to start running (not sure if this is necessary)
3. bkr job-cancel 924
  
Actual results:

Exception: exceptions.ValueError:need more than 1 value to unpack

Expected results:

(some sort of success)

Additional info:

$ cat ~/.beaker_client/config                                               HUB_URL = "https://beaker.engineering.redhat.com"
AUTH_METHOD = "krbv"
KRB_REALM = "REDHAT.COM"

Also tried with --msg="message".  No change.  Cancelling from the web GUI[1] worked fine.  Browser read "Successfully cancelled job 924" in an orange bar at top, and I received email within 2 seconds.

 [1] https://beaker.engineering.redhat.com/jobs/cancel?id=924

Original XML attached.  As it says (I hope) in the description, please treat it with suspicion.  There may be something incomplete or missing in this XML.

Comment 1 Ed Santiago 2010-05-24 20:43:26 UTC
Comment on attachment 416222 [details]
bkr-submit.xml

Eek.  Changed "Description" field to just the filename.  I misunderstood that field.

Again, please treat this XML with suspicion.  It's something created by me, without a full understanding of beaker requirements.

Comment 2 Marian Csontos 2010-06-09 14:02:33 UTC
Job should be specified in J:NNN form. bkr job-cancel can also cancel particular RecipeSets (RS:NNN) and recipes (R:NNN)

However it looks sensible making J: the default... Bill?

Comment 3 Ed Santiago 2010-06-09 14:10:14 UTC
(In reply to comment #2)
> Job should be specified in J:NNN form. 

Ah.  That wasn't clear from the help message.

Whether or not J:nnn is made the default, would it make sense to fix the error message to something more user-friendly?

  bkr: invalid taskspec '924'; for help, type bkr job-cancel --help

(updating the job-cancel help message as well)

Comment 4 Raymond Mancy 2010-06-30 05:43:35 UTC
User Guide also states it needs to be J:NNN, but yeah, kind of seems redundant.

Comment 5 Dan Callaghan 2012-02-01 04:25:22 UTC
We can make the error message here a bit more helpful.

Comment 6 Dan Callaghan 2012-02-01 06:54:25 UTC
Patch pushed to Gerrit for review.

http://gerrit.beaker-project.org/919

Comment 7 Dan Callaghan 2012-05-14 05:16:12 UTC
Deferring to 0.9.1

Comment 9 Dan Callaghan 2012-07-06 04:46:41 UTC
Patch updated on Gerrit.

Comment 12 Raymond Mancy 2012-07-17 04:36:25 UTC
[raymond@rmancy sub]$ bkr job-cancel 16500
Usage: bkr job-cancel [options] <taskspec>...

bkr: error: Invalid taskspec '16500': see "Specifying tasks" in bkr(1)

Comment 13 Dan Callaghan 2012-07-20 00:38:51 UTC
Beaker 0.9.1 has been released.

Comment 14 Dan Callaghan 2012-08-22 23:36:53 UTC
*** Bug 643882 has been marked as a duplicate of this bug. ***

Comment 15 Dan Callaghan 2012-10-17 22:14:55 UTC
*** Bug 867561 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.