Bug 867561 - help section of job-cancel and job-delete does not have usage examples
help section of job-cancel and job-delete does not have usage examples
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.18.2
: ---
Assigned To: Dan Callaghan
tools-bugs
: Patch, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 14:09 EDT by Michael Gregg
Modified: 2014-10-07 03:19 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-07 03:19:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Gregg 2012-10-17 14:09:14 EDT
Description of problem:
Including a usage example for bkr job-cancel and bkr job-delete would be very helpful.
When running job cancel and job delete, the job ID needs to be specified with "J:" before the job ID. This is not clear from the help section. 

There is a example in the man page for both commands, but a example in the cli help would be nice.

Version-Release number of selected component (if applicable):
0.8.1-6

How reproducible:
always

Steps to Reproduce:
1. bkr job-cancel <number> (ie bkr-job-cancel 33471)
  

Actual results:
bkr job-cancel 33471
XML-RPC fault: <type 'exceptions.ValueError'>:need more than 1 value to unpack

Expected results:
bkr job-cancel 33471
XML-RPC fault: <type 'exceptions.ValueError'>:need more than 1 value to unpack
Did you specify the job ID properly? Example J:1234
Comment 1 Dan Callaghan 2012-10-17 18:14:55 EDT
Michael, this has been addressed quite a while ago. Your client version if very old, please upgrade to the latest version.

$ bkr job-cancel 1234
Usage: bkr job-cancel [options] <taskspec>...

bkr: error: Invalid taskspec '1234': see "Specifying tasks" in bkr(1)

*** This bug has been marked as a duplicate of bug 595512 ***
Comment 4 Bill Peck 2014-04-14 09:36:58 EDT
job-cancel fails if you specify R:<number>.  Either the help should be updated to specify that only J:<number> and RS:<number> are valid or the command should can the recipeSet when R:<number> is specified.
Comment 5 Bill Peck 2014-04-14 09:37:32 EDT
(In reply to Bill Peck from comment #4)
> job-cancel fails if you specify R:<number>.  Either the help should be
> updated to specify that only J:<number> and RS:<number> are valid or the
> command should can the recipeSet when R:<number> is specified.

                  ^^
                 cancel
Comment 8 Dan Callaghan 2014-09-17 02:59:21 EDT
http://gerrit.beaker-project.org/3333

$ bkr job-cancel R:123
Usage: bkr job-cancel [options] [J:<id> | RS:<id> ...]

bkr: error: Taskspec type must be one of [J, RS, T]

T is in there because we allow cancelling individual recipe-tasks (bug 1124756) even though it's not documented...
Comment 11 Dan Callaghan 2014-10-07 03:19:50 EDT
Beaker 0.18.2 has been released.

Note You need to log in before you can comment on or make changes to this bug.