Bug 595564 - RFE: can xref links to formalpara go to the actual formalpara, rather than top of the page?
RFE: can xref links to formalpara go to the actual formalpara, rather than to...
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
ecs-bugs
:
: 598305 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-24 21:26 EDT by Murray McAllister
Modified: 2015-01-04 17:36 EST (History)
5 users (show)

See Also:
Fixed In Version: publican-2.1-0.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 00:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Murray McAllister 2010-05-24 21:26:42 EDT
Description of problem:
When you give a formalpara an ID, and attempt to link to that part of the document, the link goes to the top of the page that contains the formalpara, rather than to the formalpara itself. This causes issues if you have a page full of formalpara, and want to link to a specific one/part of the document.

Version-Release number of selected component (if applicable):
* publican-1.6.3-0.el5
* Red Hat Enterprise Linux Client release 5.5 (Tikanga)

How reproducible:
Always.

Steps to Reproduce:
1. create a document with a list of formalpara on a single page.
2. attempt to link to one with xref linkend.
  
Actual results:
If on the same page as the formalpara when you click the link, nothing happens. If on a different page or section, the link takes you to the top of the page containing the formalpara you are trying to get to.

Expected results:
If possible, the link takes you to the formalpara.

Additional info:
Comment 1 Jeff Fearn 2010-05-25 06:08:48 EDT
formalpara was missing it's ID. Set ID.

Build 1.6.3-0.t77
Comment 2 Murray McAllister 2010-05-25 17:39:20 EDT
Awesome, thanks for quickly fixing this!
Comment 3 Jeff Fearn 2010-05-31 23:34:18 EDT
*** Bug 598305 has been marked as a duplicate of this bug. ***
Comment 4 Murray McAllister 2010-06-27 22:24:56 EDT
Is there any time frame for a release that will contain a fix for this issue?

Thanks.
Comment 5 Jeff Fearn 2010-06-27 22:34:07 EDT
We don't have a formal schedule, so ... soon ... ish
Comment 6 Fedora Update System 2010-07-07 13:35:24 EDT
publican-2.1-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-07-07 13:39:58 EDT
publican-2.1-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.