Bug 595675 - Cannot unmount NFS share if Mount version 1 is disabled.
Summary: Cannot unmount NFS share if Mount version 1 is disabled.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils   
(Show other bugs)
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: yanfu,wang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 804218 804681
TreeView+ depends on / blocked
 
Reported: 2010-05-25 11:21 UTC by Sachin Prabhu
Modified: 2018-11-14 20:19 UTC (History)
2 users (show)

Fixed In Version: nfs-utils-1.0.9-52.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 804218 (view as bug list)
Environment:
Last Closed: 2011-07-21 11:35:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch that fixes the problem (576 bytes, patch)
2011-01-21 18:47 UTC, Steve Dickson
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1048 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2011-07-20 15:43:36 UTC

Description Sachin Prabhu 2010-05-25 11:21:35 UTC
Reproducer:

On server:
edit /etc/sysconfig/nfs and set  MOUNTD_NFS_V1=no
restart nfs

On client: 
Mount a share from the server. This should be successful.
Now try to unmount it. This fails with an error.

# umount /mnt
umount.nfs: vm22:/exports: not found / mounted or server not reachable
umount.nfs: vm22:/exports: not found / mounted or server not reachable


The cause appears to be the fact that the client when mounting uses MOUNT version 3 protocol. However when unmounting, it appears to use version 1 of the MOUNT protocol. Since version 1 is disabled, the client cannot unmount.

Comment 1 Steve Dickson 2011-01-21 18:47:14 UTC
Created attachment 474657 [details]
The patch that fixes the problem

Comment 3 yanfu,wang 2011-06-08 10:05:31 UTC
reproduced on RHEL5.6:
On server:
edit /etc/sysconfig/nfs and set  MOUNTD_NFS_V1=no
restart nfs

[root@dell-pesc430-03 ~]# mount -t nfs dell-pesc430-03.rhts.eng.bos.redhat.com:/scratch/testdir/1 /mnt/
[root@dell-pesc430-03 ~]# cat /proc/mounts 
...
dell-pesc430-03.rhts.eng.bos.redhat.com:/scratch/testdir/1 /mnt nfs rw,vers=3,rsize=32768,wsize=32768,hard,proto=tcp,timeo=600,retrans=2,sec=sys,addr=dell-pesc430-03.rhts.eng.bos.redhat.com 0 0
[root@dell-pesc430-03 ~]# umount /mnt
umount.nfs: dell-pesc430-03.rhts.eng.bos.redhat.com:/scratch/testdir/1: not found / mounted or server not reachable
umount.nfs: dell-pesc430-03.rhts.eng.bos.redhat.com:/scratch/testdir/1: not found / mounted or server not reachable

verified on RHEL5.7 with nfs-utils-1.0.9-52.el5 i386 and x86_64 package, umount is ok if mount version 1 is disabled.

Comment 4 errata-xmlrpc 2011-07-21 11:35:22 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1048.html


Note You need to log in before you can comment on or make changes to this bug.